Bug 903568 - nova scheduler doesn't report failure of selected host and reason it failed
nova scheduler doesn't report failure of selected host and reason it failed
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 05:12 EST by Ofer Blaut
Modified: 2013-02-12 10:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-12 10:55:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Failure logs on controller and compute node (5.37 KB, text/plain)
2013-01-24 05:12 EST, Ofer Blaut
no flags Details

  None (edit)
Description Ofer Blaut 2013-01-24 05:12:15 EST
Created attachment 686623 [details]
Failure logs on controller and compute node

Description of problem:

nova scheduler doesn't report failure of selected host and reason it failed

I have change nova.conf vlan_interface to non exist one 

Lanuch new VMs will fail on the compute node .

no event is seen in /var/log/nova/scheduler.log on controller,
when enabling debug some info is seen but doesn't explain what caused it 

this is problematic , in case some compute nodes are used and one fails to start VM from some reason , Error/Warrning event must be sent by nova/scheduler.log 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a setup with controller and two compute nodes
2. check VMs are deployed on both of them ( nova list , and nova show <VM ID >
to see both hosts are used for VMs
3. change interface used by private network to interface that doesn't exist
4. reboot the host
5. launch new VMs 
6. check logs in both compute node and nova/scheduler.log on controller 

Actual results:

Attached logs from this example 
Expected results:


Additional info:
Comment 2 Russell Bryant 2013-02-12 10:55:57 EST
The scheduler doesn't know why it failed.  In this case, it's a problem local to the compute node, and you do get an error that gives a hint as to what the problem is related to in the compute log.

Note You need to log in before you can comment on or make changes to this bug.