This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 903671 - Network creation by a non-admin user in FlatDHCPManager requires "vlan_start" parameter
Network creation by a non-admin user in FlatDHCPManager requires "vlan_start"...
Status: CLOSED DUPLICATE of bug 909286
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: snapshot3
: 2.1
Assigned To: Brent Eagles
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 09:46 EST by Rami Vaknin
Modified: 2016-04-26 15:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-nova-2012.2.3-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 11:23:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-01-24 09:46:19 EST
Version:
Folsom on RHEL6.4, FlatDHCPManager, openstack-nova-2012.2.2-6.el6ost.noarch

Scenario:
I'm trying to create a network by a non-admin user using the following paramters on his own project (I've tried both with and without the "--project_id" parameter), it requires a 'vlan_start' parameter although I'm working with the FlatDHCP network manager.

Note that running the same command by the admin user works well and does not require any additinal parameters.

$ nova-manage network create --label=net08_1 --fixed_range_v4=192.168.18.128/25 --bridge=br100 --project_id=4d59ca3ff6114b219dead3cf818318a5 --num_networks=1
Command failed, please check log for more info
2013-01-24 14:27:07 CRITICAL nova [req-1259bc66-4cd8-48a6-94ed-60ae8fa8f6b7 None None] 'vlan_start'
Comment 2 Russell Bryant 2013-02-12 11:14:06 EST
nova-manage doesn't go through the API, so there is no concept of admin vs non-admin.  Can you provide more specific examples of what works and what doesn't?
Comment 3 Rami Vaknin 2013-02-13 04:09:31 EST
I reproduced it, but I found the catch - I used to run the admin commands from the controller and the non-admin commands from the compute node.

my env contains one controller and two compute nodes, running the command (the one from the bug description) on the controller works well (regardless of the user running the command), but running from the compute node throws the vlan_start error.
Comment 4 Brent Eagles 2013-02-19 09:36:09 EST
Are the nova.conf files on your controller and compute nodes consistent? More specifically, does the nova.conf file on your compute node that is *not* also the controller have FlatDHCPManager configured?
Comment 5 Rami Vaknin 2013-02-19 09:50:11 EST
(In reply to comment #4)
> Are the nova.conf files on your controller and compute nodes consistent?
> More specifically, does the nova.conf file on your compute node that is
> *not* also the controller have FlatDHCPManager configured?

No, the compute's nova.conf has no network_manager entry at all, that's the way packstack configured it.
Comment 6 Brent Eagles 2013-02-19 10:31:00 EST
Heh. The if not set the default is VlanManager. I suspect that has something to do with this issue. I'll verify.
Comment 7 Rami Vaknin 2013-02-19 10:47:00 EST
(In reply to comment #6)
> Heh. The if not set the default is VlanManager. I suspect that has something
> to do with this issue. I'll verify.

There is not nova-network on the compute, so who it using this (default) value at all? isn't it a nova-network conf entry?
Comment 8 Brent Eagles 2013-02-19 10:51:01 EST
Yes, I've confirmed that is the issue. While the nova-manage admin tool does access Openstack data from the database, configuration information comes from the configuration files. Since the packstack generated configuration file omits the network_manager entry, nova-manage defaults to vlan and the relevant validation code is what is responsible for printing that message. This is more of a configuration issue and not really a nova-manage bug. It might be considered a packstack issue however.
Comment 9 Alan Pevec 2013-02-19 11:23:38 EST

*** This bug has been marked as a duplicate of bug 909286 ***

Note You need to log in before you can comment on or make changes to this bug.