Bug 90372 - /etc/init.d/snmptrapd is corrupted...
/etc/init.d/snmptrapd is corrupted...
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2003-05-07 10:48 EDT by Daniel J Blueman
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-09 10:18:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
snmptrapd init script (645 bytes, application/octet-stream)
2003-05-09 09:55 EDT, Daniel J Blueman
no flags Details

  None (edit)
Description Daniel J Blueman 2003-05-07 10:48:17 EDT
The initscript /etc/init.d/snmptrapd is corrupted with ctrl-M characters at the 
end of each line (like it's been edited in windows).

This prevents execution of it:

# /etc/init.d/snmptrapd stop  
: bad interpreter: No such file or directory
Comment 1 Phil Knirsch 2003-05-09 03:55:01 EDT
Have you tried the pending errata version:


i checked and the init files look correct in there.


Read ya, Phil
Comment 2 Daniel J Blueman 2003-05-09 06:44:33 EDT
I can confirm this RPM (as well as the one on the source media) has the same 
issues in /etc/init.d/snmptrapd.


Please confirm/deny.
Comment 3 Phil Knirsch 2003-05-09 07:44:39 EDT
Thats really wierd. I just checked this morning again the rpms on
people.redhat.com and they are correct. So i really wonder why your packages
seem to be corrupt...

Could you do a

rpm -q ucd-snmp

on your machine and attach your /etc/rc.d/init.d/snmptrapd to this bugzilla entry?


Read ya, Phil

Comment 4 Daniel J Blueman 2003-05-09 09:55:18 EDT
Created attachment 91582 [details]
snmptrapd init script
Comment 5 Daniel J Blueman 2003-05-09 09:56:13 EDT
$ rpm -q ucd-snmp

Information and file supplied (targz'd to prevent mailer and/or samba mangling 
Comment 6 Phil Knirsch 2003-05-09 09:59:16 EDT
OK, that is to be expected. The snmptrapd file was corrupted in that release.
Please download and install the latest pending errata version from
people.redhat.com/pknirsch/ and see if that still has the corrupted init files.
(it shouldn't, i verified that this morning).


Read ya, Phil

PS: These packages also fix various other small problems, so it's a really good
idea to update anyway. :-)

Note You need to log in before you can comment on or make changes to this bug.