Bug 90392 - mkbootdisk does not support ISO file system
Summary: mkbootdisk does not support ISO file system
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mkbootdisk (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-07 16:51 UTC by Boris Mironov
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 22:52:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Boris Mironov 2003-05-07 16:51:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
mkbootdisk does not support ISO images.

That is "have to have" feature for Advanced Server recovery process because 
image is bigger than regular floppy disk. Especially when it is available for 
Linux Red Hat 8.0

Please promote newer rmp to "advance Server" tree with following fix for 
v1.4.8:

*** mkbootdisk.orig	2002-11-05 01:09:04.000000000 -0500
--- mkbootdisk	2002-11-06 14:41:05.000000000 -0500
***************
*** 3,8 ****
--- 3,10 ----
  # mkbootdisk
  #
  # Written by Erik Troan 
+ #
+ # Additions by Micah Silverman 
  
  pause=yes
  unset kernel
***************
*** 247,252 ****
--- 249,259 ----
  [ -n "$verbose" ] && echo "done."
  
  if [ -n "$isoimage" ]; then
+     # additions by Micah Silverman start
+     mkdir $MOUNTDIR/boot
+     cp -p -r /boot/* $MOUNTDIR/boot
+     # additions by Micah Silverman end
+ 
      mkisofs \
  	-A "Red Hat Linux Boot CD" \
  	-V "Red Hat Linux Boot CD" \


Best regards,
Boris

Version-Release number of selected component (if applicable):
1.4.2-3

How reproducible:
Always

Steps to Reproduce:
1. mkbootdisk --device bootcd.iso --iso 2.4.9-e.14smp
    

Actual Results:  Does not support ISO-image

Expected Results:  Administrator should be able to create bootable disk for 
system recovery

Additional info:

Comment 1 Matt Wilson 2003-10-09 22:52:22 UTC
--iso is not a valid option in 1.4.2-3 (see mkbootdisk --help)



Note You need to log in before you can comment on or make changes to this bug.