Bug 90409 - redhat-config-xfree86 fails to generate working XF86Config file
redhat-config-xfree86 fails to generate working XF86Config file
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-07 15:50 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 11:07:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log file from failed attempt to run X. (28.98 KB, text/plain)
2003-05-07 15:51 EDT, Need Real Name
no flags Details
incorrect XF86COnfig file created by redhat-config-xfree86 (3.06 KB, text/plain)
2003-05-07 15:56 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-05-07 15:50:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
The XF86Config file created during install (or by running redhat-config-xfree96
after the install is complete) does not work:  X won't start.   I will attach an
XFree86.0.log file from a failed attempt to run X, and the XF86Config file
created by redhat-config-xfree86.

The problem appears to be incorrect HorizSync and VertRefresh values in
XF86Config:  X runs fine if I edit XF86Config and substitute HorizSync and
VertRefresh values from an older XF86Config file (from an earlier RHL release).

The system is a Dell Lattitude c800 laptop.  The video card is an ATI Rage
Mobility M4 AGP, and the display is a 1600x1200 LCD panel.

Version-Release number of selected component (if applicable):
0.7.3-2

How reproducible:
Always

Steps to Reproduce:
1. install or run redhat-config-xfree86
2. type "startx" at the command prompt
    

Actual Results:  X won't run.

Expected Results:  X should run.

Additional info:
Comment 1 Need Real Name 2003-05-07 15:51:33 EDT
Created attachment 91535 [details]
XFree86 log file from failed attempt to run X.
Comment 2 Need Real Name 2003-05-07 15:56:17 EDT
Created attachment 91536 [details]
incorrect XF86COnfig file created by redhat-config-xfree86

The values for HorizSync (31.5 - 37.9) and VertRefresh (50.0 - 70.0) are
incorrect for my hardware.

These values work:
HorizSync     30.0 - 94.0
VertRefresh   50.0 - 75.0
Comment 3 Brent Fox 2003-09-17 12:38:46 EDT
If you move /etc/X11/XF86Config file out of the way, will redhat-config-xfree86
even run?  
Comment 4 Need Real Name 2003-09-17 21:53:08 EDT
No.  I moved /etc/X11/XF86Config, and ran "redhat-config-xfree" (at the
console).  I didn't get an XF86Config file.  Instead I got these error messages:

* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Couldn't start X server, trying with a fresh configuration
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Trying with card: ATI Rage 128 Mobility
Error cannot start X server.



I also tried running "redhat-config-xfree --noui" (at the console).  Adding the
"--noui" option results in generation of a new XF86Config file, but it doesn't
work (same problem as noted earlier in this bug report).  I also get these error
messages:

* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
Comment 5 Brent Fox 2004-02-24 15:18:44 EST
*** Bug 88290 has been marked as a duplicate of this bug. ***
Comment 6 Brent Fox 2004-02-25 11:07:45 EST
Hmm, I don't really know what to do here.  I have a Compaq laptop with
an ATI Rage Mobility.  Mine works fine, but the difference is that my
screen is 1024x768 and yours is 1600x1200.

Many laptop screens cannot be properly probed that other monitors can.
 In this situation, we try to load some safe sync rate ranges that
should allow most monitors to work (it's designed to be 800x600).

For some reason, these default sync rates aren't working in your case.
 The problem is that if I were to change the default rates to make
your screen work, it would likely cause problems with other monitors.

The only workaround I can think of for you is to manually specify the
sync rates from the command line:

'redhat-config-display --set-vsync=50.0-70.0 --set-hsync=30.0-94.0'

That should create a working XF86Config file.  Other than that, I
don't think there's much I can do to make all monitors work in all
situations, especially when I can't detect the model from the
monitor's firmware.

Note You need to log in before you can comment on or make changes to this bug.