Bug 90420 - redhat-config-network crashes immediately after opening
redhat-config-network crashes immediately after opening
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-07 19:05 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-15 06:35:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump (1.53 KB, text/plain)
2003-05-07 19:08 EDT, Need Real Name
no flags Details
Second error dump (1.53 KB, text/plain)
2003-05-09 10:53 EDT, Need Real Name
no flags Details
/etc/sysconfig/networking/devices/ifcfg-eth0 (377 bytes, text/plain)
2003-05-09 11:34 EDT, Need Real Name
no flags Details
Conf.py (61.36 KB, text/plain)
2003-05-12 12:17 EDT, Harald Hoyer
no flags Details
log.py (1.79 KB, text/plain)
2003-05-13 04:02 EDT, Harald Hoyer
no flags Details

  None (edit)
Description Need Real Name 2003-05-07 19:06:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-4smp i686)

Description of problem:
Immediately upon typing "redhat-config-network" and hitting "enter" (or
selecting the Network Configuration item from the menu), the network
configuration GUI partially opens and a message appears saying an error has
occurred (attached).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. type "redhat-config-network" (as root)
2. the GUI has now partially appeared along with a window telling you that an
error occurred and the dump listed in the "Description" box in this bug report
3.
    

Actual Results:  The redhat-config-network GUI crashed.

Expected Results:  The redhat-config-network GUI should have opened.

Additional info:
Comment 1 Need Real Name 2003-05-07 19:08:54 EDT
Created attachment 91545 [details]
Dump
Comment 2 Harald Hoyer 2003-05-08 04:54:53 EDT
which version is this?
$ rpm -q redhat-config-network
will find out.
Have you upgraded to the latest erratum via RHN or ftp?
Comment 3 Need Real Name 2003-05-08 12:35:37 EDT
The version is: redhat-config-network-1.0.0-1
Yes, the latest erratum had been applied via RHN the day before I encountered
this bug.
Comment 4 Harald Hoyer 2003-05-09 04:17:05 EDT
for 7.3 there is a 1.0.4-2 erratum available..
Comment 5 Need Real Name 2003-05-09 10:53:44 EDT
Created attachment 91583 [details]
Second error dump
Comment 6 Need Real Name 2003-05-09 10:55:09 EDT
I've upgraded to redhat-config-network-1.0.4-2 (sidenote: Why didn't this update
happen with a plain 'up2date'? I had to do an 'up2date redhat-config-network'
afterwards.) Unfortunately, this didn't correct the behavior of the application.
The new error message dump is attached.
Comment 7 Harald Hoyer 2003-05-09 10:59:25 EDT
please attach /etc/sysconfig/networking/devices/ifcfg-eth0
Comment 8 Need Real Name 2003-05-09 11:34:09 EDT
Created attachment 91586 [details]
/etc/sysconfig/networking/devices/ifcfg-eth0

Here is the file you requested.
Comment 9 Harald Hoyer 2003-05-09 11:55:45 EDT
I am puzzled... could you please remove the last duplicate line of
ifcfg-eth0 with an editor and insert a newline instead and retry?
Never saw this error...
Comment 10 Harald Hoyer 2003-05-09 11:56:25 EDT
or just remove all IPX lines if you can?
Comment 11 Need Real Name 2003-05-09 12:43:12 EDT
I have removed all of the IPX lines from the
/etc/sysconfig/networking/devices/ifcfg-eth0 file. I still get exactly the same
error.
Comment 12 Harald Hoyer 2003-05-12 10:54:26 EDT
there is a newline missing at the end of your file... just add an empty line at
the end and the problem should be gone. I will consider this in my next bugfix.
Comment 13 Need Real Name 2003-05-12 12:02:27 EDT
Unfortunately, I cannot seem to just add an empty line at the end of this file.
Every time I try adding an empty line and saving it, the next time I run
"redhat-config-network" it acts just the same -- crashing with the error message
attached earlier. When I re-open the file after that, I find that my change (the
addition of the newline) has been deleted. How do I prevent this from happening?
Comment 14 Harald Hoyer 2003-05-12 12:17:02 EDT
Created attachment 91623 [details]
Conf.py

copy Conf.py to /usr/share/redhat-config-network/netconfpkg/Conf.py
Comment 15 Harald Hoyer 2003-05-12 12:19:23 EDT
can you please try out the Conf.py which should bugfix your version
Comment 16 Need Real Name 2003-05-12 12:45:29 EDT
I copied over the new Conf.py file. Now I get this error:

% redhat-config-network
Traceback (innermost last):
  File "/usr/sbin/neat", line 49, in ?
    from netconfpkg import *
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/__init__.py", line
40, in ?
    exec cmd
  File "<string>", line 1, in ?
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 157,
in ?
    from log import log
ImportError: No module named log
Comment 17 Harald Hoyer 2003-05-13 04:02:21 EDT
Created attachment 91640 [details]
log.py

copy to the same place as Conf.py
Comment 18 Need Real Name 2003-05-13 12:19:02 EDT
Now a call to "redhat-config-network" results in a message: "Copying ifcfg-eth0
to devices and putting it into the default profile" and the opening of the
network configuration GUI. I still suspect that the "redhat-config-network" tool
may not be operating as optimally as perhaps it should be. (For example I now
have an "eth0.old" inactive device which still seems to be listed as having
"Active" status even though the "Activate" button is active and the "Deactivate"
one is not.) However, the bug that is the subject of this bug report appears to
be fixed -- the utility opens successfully and allows me to modify the network
configuration. Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.