Bug 90452 - docbook-utils.dsl: %use-id-as-filename% #f breaks Gnome help documentation file names
docbook-utils.dsl: %use-id-as-filename% #f breaks Gnome help documentation fi...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
7.3
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 90464 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 11:37 EDT by Leif Harcke
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 11:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leif Harcke 2003-05-08 11:37:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
Turning off %use-id-as-filename% in the docbook-utils.dsl stylesheet has broken
the standard filename structure when building Gnome help documentation for Balsa
(and probably other applications).

Version-Release number of selected component (if applicable):
docbook-utils-0.6.9-25

How reproducible:
Always

Steps to Reproduce:
0.install Gnome PNG DocBook DTD's for DocBook 3.0 and 3.1
http://cvs.gnome.org/lxr/source/gnome-docu/gdp/gnome-doc-tools/

1.download balsa-1.4.3.tar.bz2 (or earlier versions)
2.unpack and cd balsa-1.4.3/help/C
3.jw -o balsa balsa.sgml

Actual Results:  ls balsa/*.html

x1454.html
x1490.html
x1537.html
x1581.html
x1584.html
x1656.html
x1722.html
x1747.html
x1770.html
x1857.html
x1920.html
x501.html
x51.html
x81.html
x983.html
x986.html
g1983.html
index.html
ln7.html
t1.htm

Expected Results:  authors.html
glossary.html
index.html
its-not-working.html
common-tasks.html
identities.html
mbox-formats.html
toolbars.html
win-filters.html
win-run-filters.html
ab-conf.html
folder-config.html
preferences-2.html
preferences-3.html
preferences-4.html
preferences-5.html
preferences-6.html
preferences-0.html
preferences-1.html
preferences.html
win-composer.html
win-message.html
getting-started.html
win-main.html
LICENSE.html



Additional info:

from the ChangeLog for docbook-utils:

2002-05-01  Tim Waugh  <twaugh@redhat.com>

        * docbook-utils.dsl: Turn off %use-id-as-filename%.

Why was it turned off?
Comment 1 Tim Waugh 2003-05-08 11:43:49 EDT
For security.

Use a custom stylesheet, or just use -V (like the docbook-utils tarball does
itself when building).  No bug here.
Comment 2 Tim Waugh 2003-05-08 12:53:01 EDT
*** Bug 90464 has been marked as a duplicate of this bug. ***
Comment 3 Leif Harcke 2003-05-08 15:56:42 EDT
Sorry about the duplicate bug submission, first time bugzilla user. 

There is another problem with building Gnome documentation, that being 
the PNG Variant 3.0 and 3.1 DTD's aren't included in Red Hat anywhere.

The question is, should this be reported as a problem with docbook-dtds, or with
one of the Gnome packages, such as gnome-user-docs?  Perhaps a new package is
called for, gnome-user-docs-devel, which contains the DTDs and the Gnome
documentaton specific stylesheet?
Comment 4 Tim Waugh 2003-05-09 04:22:29 EDT
Against gnome-user-docs I think; yes, a new package probably would be the way to go.

Note You need to log in before you can comment on or make changes to this bug.