Bug 90464 - docbook-utils.dsl: %use-id-as-filename% #f breaks Gnome help documentation file names
docbook-utils.dsl: %use-id-as-filename% #f breaks Gnome help documentation fi...
Status: CLOSED DUPLICATE of bug 90452
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
7.3
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 12:50 EDT by Leif Harcke
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leif Harcke 2003-05-08 12:50:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
Turning off %use-id-as-filename% in the docbook-utils.dsl stylesheet has broken
the standard filename structure when building Gnome help documentation for Balsa
(and probably other applications).

Version-Release number of selected component (if applicable):
docbook-utils-0.6.9-25

How reproducible:
Always

Steps to Reproduce:
0.install Gnome PNG DocBook DTD's for DocBook 3.0 and 3.1
http://cvs.gnome.org/lxr/source/gnome-docu/gdp/gnome-doc-tools/

1.download balsa-1.4.3.tar.bz2 (or earlier versions)
2.unpack and cd balsa-1.4.3/help/C
3.jw -o balsa balsa.sgml

Actual Results:  ls balsa/*.html

x1454.html
x1490.html
x1537.html
x1581.html
x1584.html
x1656.html
x1722.html
x1747.html
x1770.html
x1857.html
x1920.html
x501.html
x51.html
x81.html
x983.html
x986.html
g1983.html
index.html
ln7.html
t1.htm

Expected Results:  authors.html
glossary.html
index.html
its-not-working.html
common-tasks.html
identities.html
mbox-formats.html
toolbars.html
win-filters.html
win-run-filters.html
ab-conf.html
folder-config.html
preferences-2.html
preferences-3.html
preferences-4.html
preferences-5.html
preferences-6.html
preferences-0.html
preferences-1.html
preferences.html
win-composer.html
win-message.html
getting-started.html
win-main.html
LICENSE.html



Additional info:

from the ChangeLog for docbook-utils:

2002-05-01  Tim Waugh  <twaugh@redhat.com>

        * docbook-utils.dsl: Turn off %use-id-as-filename%.

Why was it turned off?
Comment 1 Tim Waugh 2003-05-08 12:52:55 EDT

*** This bug has been marked as a duplicate of 90452 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.