Bug 90474 - tcl crashes when executing ctype command
Summary: tcl crashes when executing ctype command
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-08 19:09 UTC by Kyle Bateman
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 07:06:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kyle Bateman 2003-05-08 19:09:46 UTC
Description of problem:
When executing the ctype tcl command, the program gives the following error and
then aborts:

TclX_CtypeObjCmd: UTF character longer than a int
Aborted


Version-Release number of selected component (if applicable):
tcl-8.3.5-88

How reproducible:
Always

Steps to Reproduce:
1. tcl
2. ctype digit 1

    

Actual Results:  Gives error:
TclX_CtypeObjCmd: UTF character longer than a int


Expected Results:  Should print a "1"

Comment 1 Jens Petersen 2003-05-09 01:01:35 UTC
Can you explainly more carefully how to reproduce this, please?

I see:

~% tclsh
% ctype
invalid command name "ctype"
% ctype digit 1
invalid command name "ctype"


Comment 2 Kyle Bateman 2003-05-09 04:00:51 UTC
Looks like ctype is part of tclX (not standard tcl) so you have to use "tcl" not
"tclsh" to see the right error.  If that doesn't work, try the shell script:

#!/usr/bin/tcl
ctype digit 1



Comment 3 Jens Petersen 2003-05-09 05:24:29 UTC
Thanks, reproduced.

Comment 4 Jens Petersen 2004-02-26 07:06:41 UTC
Seems to be fixed with tcl-8.3.5-1 in FC devel.

Comment 5 Jens Petersen 2004-02-27 04:11:09 UTC
tclx-8.3.5-1, I mean.


Note You need to log in before you can comment on or make changes to this bug.