Bug 904804 - Volumes: creation date of vulmes is parsed/displayed incorrectly
Volumes: creation date of vulmes is parsed/displayed incorrectly
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity low
: snapshot4
: 2.1
Assigned To: Matthias Runge
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 10:48 EST by Yaniv Kaul
Modified: 2013-07-03 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 06:30:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2013-01-27 10:48:54 EST
Description of problem:
I've created a domain at 17:42 IL time (which is +2 from GMT).
[root@ykaul-os-horizon ~(keystone_ykaul)]$ cinder show d0ae9c56-d3e0-4a72-8809-173af3fae1a1 |grep created
|      created_at     |      2013-01-27T15:42:53.000000      |

But the UI shows:
Created
Jan. 27, 2013, 9:42 a.m.


Version-Release number of selected component (if applicable):
python-django-horizon-2012.2.1-2.el6ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Julie Pichon 2013-01-28 06:40:01 EST
Horizon uses the timezone defined in the user settings to adjust the time displayed in the UI. Is it possible a different timezone is set up there?

I'm having trouble reproducing it, creating a volume either from the web UI or from the command line. Could you provide additional information?
1. How did you create the volume?
2. On the command line, what is the 'date' output? (Correct timezone?)
3. In the Horizon settings, what is the timezone set to in the user settings?

Thank you.
Comment 3 Yaniv Kaul 2013-01-28 06:50:42 EST
(In reply to comment #2)
> Horizon uses the timezone defined in the user settings to adjust the time
> displayed in the UI. Is it possible a different timezone is set up there?

Ah, mine was UTC. Why isn't it taking it from the client ?

> 
> I'm having trouble reproducing it, creating a volume either from the web UI
> or from the command line. Could you provide additional information?
> 1. How did you create the volume?

I've created it via the UI.

> 2. On the command line, what is the 'date' output? (Correct timezone?)
> 3. In the Horizon settings, what is the timezone set to in the user settings?

UTC, unfortunately.

> 
> Thank you.
Comment 4 Yaniv Kaul 2013-01-28 07:34:06 EST
Even though my user's date was UTC, the time doesn't match.
Comment 5 Matthias Runge 2013-01-28 07:45:19 EST
Actually, I have seen those issues in the past with various OpenStack services. I couldn't find a reason for this. Especially in the log files are noted time stamps lagging exactly +-5/+-6 hours around UTC.
Comment 6 Matthias Runge 2013-02-11 05:45:26 EST
Creating via cli:

[mrunge@turing ~]$ date -u
Mon Feb 11 10:40:10 UTC 2013
[mrunge@turing ~]$ date 
Mon Feb 11 11:40:12 CET 2013
[mrunge@turing ~]$ cinder create 1
+---------------------+--------------------------------------+
|       Property      |                Value                 |
+---------------------+--------------------------------------+
|     attachments     |                  []                  |
|  availability_zone  |                 nova                 |
|      created_at     |      2013-02-11T10:40:38.099052      |
| display_description |                 None                 |
|     display_name    |                 None                 |
|          id         | ac35ead3-2363-4478-88bf-f444130f8088 |
|       metadata      |                  {}                  |
|         size        |                  1                   |
|     snapshot_id     |                 None                 |
|        status       |               creating               |
|     volume_type     |                 None                 |
+---------------------+--------------------------------------+

and that's also the time displayed in horizon:

Size
    1 GB
Created
    Feb. 11, 2013, 10:40 a.m. 

investigating the other way around, will update later.
Comment 7 Matthias Runge 2013-02-12 05:13:31 EST
creating a volume from horizon shows me in horizon and from cinder show the same time stamps. So, I can not reproduce your bug here.

Is there anything, how I can reproduce it?
Comment 8 Yaniv Kaul 2013-02-12 12:16:20 EST
(In reply to comment #7)
> creating a volume from horizon shows me in horizon and from cinder show the
> same time stamps. So, I can not reproduce your bug here.
> 
> Is there anything, how I can reproduce it?

I wonder if it's due to the difference in the user time setting in Horizon (and what I have as the user in the console). 
My user had UTC as the date, while in console it was IL (GMT+2), perhaps that was it? I'll try to reproduce regardless.
Comment 9 Matthias Runge 2013-02-18 06:21:02 EST
> I wonder if it's due to the difference in the user time setting in Horizon
> (and what I have as the user in the console). 
> My user had UTC as the date, while in console it was IL (GMT+2), perhaps
> that was it? I'll try to reproduce regardless.

Since we were unable to reproduce this bug, I'd tend to close it. 

Have you any news for this bug, Yaniv?
Comment 10 Yaniv Kaul 2013-02-18 06:30:27 EST
(In reply to comment #9)
> > I wonder if it's due to the difference in the user time setting in Horizon
> > (and what I have as the user in the console). 
> > My user had UTC as the date, while in console it was IL (GMT+2), perhaps
> > that was it? I'll try to reproduce regardless.
> 
> Since we were unable to reproduce this bug, I'd tend to close it. 
> 
> Have you any news for this bug, Yaniv?

No, I'll re-open if I manage to reproduce.

Note You need to log in before you can comment on or make changes to this bug.