This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 90502 - No multipath routes in zebra
No multipath routes in zebra
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: zebra (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 17:43 EDT by Michael Stefaniuc
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 11:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Stefaniuc 2003-05-08 17:43:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
The kernel has the IP Route Multipath Option activated to allow routing (load
balancing) over different paths with the same cost but zebra can't inject
multipath routes. This is due to zebra being configured with the default
--enable-mutipath=1 (only one route to a net/host with the same cost).
Please change the spec file to configure with --enable-mutipath=0 (unlimited
routes to a net/host with the same cost).
It's not urgent cause the user can always add the option themselfs and recompile.

Version-Release number of selected component (if applicable):
zebra-0.93b-1

How reproducible:
Always

Steps to Reproduce:
1. look at the spec file and zebra's configure script
2.
3.
    

Actual Results:  no --enable-mutipath=0 in the configure command line in the
spec file and default is --enable-mutipath=1

Expected Results:  --enable-mutipath=0 in the configure command line in the spec
file

Additional info:  the same problem affects the zebra shipped with RHL 8.0
Comment 1 Jay Fenlason 2004-06-30 11:35:56 EDT
--enable-multipath appears to be turned on in the quagga-0.96.5-1 rpms
in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.