Bug 905215 - [abrt] gretl-1.9.11-1.fc17: ms_ole_open: Process /usr/bin/gretl_x11 was killed by signal 7 (SIGBUS)
[abrt] gretl-1.9.11-1.fc17: ms_ole_open: Process /usr/bin/gretl_x11 was kille...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gretl (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hannes
Fedora Extras Quality Assurance
abrt_hash:7a0ad45d69d321be4e895eec51e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 16:34 EST by cryogenium
Modified: 2013-02-22 01:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-22 01:16:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (3.29 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: environ (1.26 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: var_log_messages (154 bytes, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: backtrace (85.22 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: cgroup (128 bytes, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: smolt_data (2.54 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: executable (18 bytes, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: maps (26.35 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: dso_list (8.28 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: build_ids (3.60 KB, text/plain)
2013-01-28 16:34 EST, cryogenium
no flags Details
File: proc_pid_status (785 bytes, text/plain)
2013-01-28 16:35 EST, cryogenium
no flags Details
File: open_fds (460 bytes, text/plain)
2013-01-28 16:35 EST, cryogenium
no flags Details

  None (edit)
Description cryogenium 2013-01-28 16:34:25 EST
Version-Release number of selected component:
gretl-1.9.11-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/gretl_x11
crash_function: ms_ole_open
kernel:         3.7.3-101.fc17.i686

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 ms_ole_open at ../plugin/libole2/ms-ole.c:785
: #1 process_sheet at excel_import.c:904
: #2 xls_get_data at excel_import.c:1594
: #3 get_imported_data at gui_utils.c:1011
: #4 do_open_data at gui_utils.c:1193
: #5 verify_open_data at gui_utils.c:1218
: #6 file_selector_process_result at fileselect.c:518
: #7 gtk_file_selector at fileselect.c:937
: #8 open_data at callbacks.c:214
: #14 _gtk_action_emit_activate at gtkaction.c:795
Comment 1 cryogenium 2013-01-28 16:34:28 EST
Created attachment 689347 [details]
File: core_backtrace
Comment 2 cryogenium 2013-01-28 16:34:30 EST
Created attachment 689348 [details]
File: environ
Comment 3 cryogenium 2013-01-28 16:34:33 EST
Created attachment 689349 [details]
File: var_log_messages
Comment 4 cryogenium 2013-01-28 16:34:35 EST
Created attachment 689350 [details]
File: limits
Comment 5 cryogenium 2013-01-28 16:34:38 EST
Created attachment 689351 [details]
File: backtrace
Comment 6 cryogenium 2013-01-28 16:34:41 EST
Created attachment 689352 [details]
File: cgroup
Comment 7 cryogenium 2013-01-28 16:34:48 EST
Created attachment 689353 [details]
File: smolt_data
Comment 8 cryogenium 2013-01-28 16:34:50 EST
Created attachment 689354 [details]
File: executable
Comment 9 cryogenium 2013-01-28 16:34:54 EST
Created attachment 689355 [details]
File: maps
Comment 10 cryogenium 2013-01-28 16:34:57 EST
Created attachment 689356 [details]
File: dso_list
Comment 11 cryogenium 2013-01-28 16:34:59 EST
Created attachment 689357 [details]
File: build_ids
Comment 12 cryogenium 2013-01-28 16:35:01 EST
Created attachment 689358 [details]
File: proc_pid_status
Comment 13 cryogenium 2013-01-28 16:35:04 EST
Created attachment 689359 [details]
File: open_fds
Comment 14 hannes 2013-02-01 00:47:55 EST
Hello,

I filed your bug report upstream at http://sourceforge.net/p/gretl/bugs/175/ the upstream developer would like to see the used .xls file, of course you could remove/replace the important parts.
I hope you could provide an anonymous copy of that file, so that it's possible to fix the crash. 
Thanks
Comment 15 cryogenium 2013-02-03 15:25:18 EST
(In reply to comment #14)
> Hello,
> 
> I filed your bug report upstream at http://sourceforge.net/p/gretl/bugs/175/
> the upstream developer would like to see the used .xls file, of course you
> could remove/replace the important parts.
> I hope you could provide an anonymous copy of that file, so that it's
> possible to fix the crash. 
> Thanks

I'm sorry, it was testing file and I removed it because I hadn't further use for it and I doesn't thinked that it will be needed for debugging.

Mikko
Comment 16 hannes 2013-02-04 00:47:12 EST
Well, unfortunately the original author of gretl seems to disagree here. I think without the xls file there is no way to debug the error.

Note You need to log in before you can comment on or make changes to this bug.