Bug 90522 - 1013:6001 incorrectly set to cs46xx?
1013:6001 incorrectly set to cs46xx?
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: hwdata (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-09 05:00 EDT by Warren Togami
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-18 20:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2003-05-09 05:00:40 EDT
Description of problem:
Device 1013:6001 as defined in hwdata pcitable is the Crystal Sound CS46xx
device, however this machine has the following errors when attempting to load
this module:

[root@localhost hwdata]# modprobe cs46xx
/lib/modules/2.4.20-8/kernel/drivers/sound/cs46xx.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-8/kernel/drivers/sound/cs46xx.o: insmod
/lib/modules/2.4.20-8/kernel/drivers/sound/cs46xx.o failed
/lib/modules/2.4.20-8/kernel/drivers/sound/cs46xx.o: insmod cs46xx failed

dmesg errors....

PCI: Found IRQ 10 for device 00:0b.0
Crystal 4280/46xx + AC97 Audio, version 1.28.32, 18:00:03 Mar 13 2003
cs46xx: Card found at 0xf4100000 and 0xf4000000, IRQ 10
cs46xx: Card without SSID set (0000:0000) at 0xf4100000/0xf4000000, IRQ 10
cs46xx: create - never read card ready from AC'97
cs46xx: probably not a bug, try using the CS4232 driver,
cs46xx: or turn off any automatic Power Management support in the BIOS.
cs46xx: create - never read card ready from AC'97
cs46xx: probably not a bug, try using the CS4232 driver,
cs46xx: or turn off any automatic Power Management support in the BIOS.
cs46xx: create - never read card ready from AC'97
cs46xx: probably not a bug, try using the CS4232 driver,
cs46xx: or turn off any automatic Power Management support in the BIOS.
cs46xx: create - never read card ready from AC'97
cs46xx: probably not a bug, try using the CS4232 driver,
cs46xx: or turn off any automatic Power Management support in the BIOS.
cs46xx: create - never read card ready from AC'97
cs46xx: probably not a bug, try using the CS4232 driver,
cs46xx: or turn off any automatic Power Management support in the BIOS.
cs46xx: cs46xx_probe()- cs_hardware_init() failed, retried 5 times.
cs46xx: probe()- no device allocated
cs46xx: Unable to detect valid cs46xx device


Sound works fine when loading the cs4232 driver as suggested by the dmesg error
messages above.

[root@localhost hwdata]# modprobe cs4232
ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
ad1848: WSS/SB detected
ad1848: ISAPnP reports 'WSS/SB' at i/o 0x534, irq 5, dma 1, 3
cs4232: set synthio and synthirq to use the wavefront facilities.

Hardware:
Micron Millenia
Pentium II 400MHz


00:0b.0 Multimedia audio controller: Cirrus Logic CS 4610/11 [CrystalClear
SoundFusion Audio Accelerator] (rev 01)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (1000ns min, 6000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at f4100000 (32-bit, non-prefetchable) [size=4K]
        Region 1: Memory at f4000000 (32-bit, non-prefetchable) [size=1M]

00:0b.0 Class 0401: 1013:6001 (rev 01)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (1000ns min, 6000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at f4100000 (32-bit, non-prefetchable) [size=4K]
        Region 1: Memory at f4000000 (32-bit, non-prefetchable) [size=1M]

Version-Release number of selected component (if applicable):
hwdata-0.75-1
Red Hat Linux 9

How reproducible:
Always
Comment 1 Bill Nottingham 2003-05-18 20:24:42 EDT
Unfortunately, in the *majority* of cases, that PCI id does use the cs46xx
driver. Since your particular variant doesn't have a subsystem/subvendor PCI id
to identify it with, judging by the lspci -v output you posted, there's nothing
we can really do to blacklist cs46xx in this case.

Note You need to log in before you can comment on or make changes to this bug.