Bug 90523 - post scriplet fails
post scriplet fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pango (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-09 05:15 EDT by Sepp Rudel
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 12:45:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sepp Rudel 2003-05-09 05:15:19 EDT
Description of problem:
While I was updating from RHL7.3->RHL9 with apt (yea, I know, not supported by
RH, but read on...), pango gave following error:

  57:pango                  ########################################### [  8%]
/usr/bin/pango-querymodules: error while loading shared libraries: libXft.so.2:
cannot open shared object file: No such file or directory
error: execution of %post scriptlet from pango-1.2.1-3 failed, exit status 127

Probably caused by the fact that also RPM containing libXft.so.2 was about to be
updated after pango during the same "rpm -Uvh" run. This caused two pango
packages to be in system and pango to be misconfigured. This might well happen
also with up2date/rpm -Fvh/yum/etc.


Version-Release number of selected component (if applicable):
All, I presume.

How reproducible:
Always.

Steps to Reproduce:
1.update pango and XFree86 RPMs in the same run, XFree86 RPMs with new libXft.so
    
Actual results:
pango install fails.


Expected results:
pango install ok.


Additional info:
If nothing else, please tweak %post script so that it returns 0 even if
/usr/bin/pango-querymodules fails so that only one pango RPM is left to the system.
Comment 1 Sepp Rudel 2003-05-09 05:22:55 EDT
I also mention that during RHL7.3->RHL9 update, out of about 700 RPMs only pango
and gtk2 gave errors, so otherwise looking real good. gtk2 report is #90524.
Comment 2 Owen Taylor 2003-08-28 12:45:16 EDT
I certainly don't want to change the %post -- if pango-querymodules
fails, that's a serious problem and you probably won't get any
text in GNOME.

I discussed things with various people here, and the conclusion
was that Xft should have been installed before Pango with the 
current Pango RPM

 A) There was a bug in the old Red Hat 7.3 RPM
 B) Apt wasn't correctly using RPM

The fact that Pango requires libXft.so.2 is enough to make RPM
install the Xft RPM first.

Note You need to log in before you can comment on or make changes to this bug.