Bug 905309 - [abrt] bacula-console-bat-5.2.12-6.fc18: e_msg: Process /usr/sbin/bat was killed by signal 11 (SIGSEGV)
[abrt] bacula-console-bat-5.2.12-6.fc18: e_msg: Process /usr/sbin/bat was kil...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
abrt_hash:14fdb1cee4353a67c8090fd66b5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 01:36 EST by Bob Clayton
Modified: 2013-02-15 19:55 EST (History)
8 users (show)

See Also:
Fixed In Version: bacula-5.2.12-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 19:52:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.85 KB, text/plain)
2013-01-29 01:36 EST, Bob Clayton
no flags Details
File: cgroup (126 bytes, text/plain)
2013-01-29 01:36 EST, Bob Clayton
no flags Details
File: core_backtrace (3.15 KB, text/plain)
2013-01-29 01:36 EST, Bob Clayton
no flags Details
File: dso_list (17.72 KB, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details
File: environ (3.19 KB, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details
File: maps (90.29 KB, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details
File: open_fds (612 bytes, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details
File: proc_pid_status (986 bytes, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details
File: var_log_messages (1.72 KB, text/plain)
2013-01-29 01:37 EST, Bob Clayton
no flags Details

  None (edit)
Description Bob Clayton 2013-01-29 01:36:44 EST
Version-Release number of selected component:
bacula-console-bat-5.2.12-6.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/sbin/bat -c /etc/bacula/bat.conf
crash_function: e_msg
executable:     /usr/sbin/bat
kernel:         3.7.4-204.fc18.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 e_msg at message.c:1233
 #1 Console::populateLists at console/console.cpp:157
 #2 MainWin::popLists at mainwin.cpp:122
 #3 QMetaObject::activate at kernel/qobject.cpp:3539
 #4 QSingleShotTimer::timerEvent at kernel/qtimer.cpp:317
 #5 QObject::event at kernel/qobject.cpp:1156
 #6 QApplicationPrivate::notify_helper at kernel/qapplication.cpp:4562
 #7 QApplication::notify at kernel/qapplication.cpp:4423
 #8 QCoreApplication::notifyInternal at kernel/qcoreapplication.cpp:946
 #9 sendEvent at kernel/qcoreapplication.h:231

Potential duplicate: bug 842035
Comment 1 Bob Clayton 2013-01-29 01:36:48 EST
Created attachment 689583 [details]
File: backtrace
Comment 2 Bob Clayton 2013-01-29 01:36:49 EST
Created attachment 689584 [details]
File: cgroup
Comment 3 Bob Clayton 2013-01-29 01:36:59 EST
Created attachment 689585 [details]
File: core_backtrace
Comment 4 Bob Clayton 2013-01-29 01:37:00 EST
Created attachment 689586 [details]
File: dso_list
Comment 5 Bob Clayton 2013-01-29 01:37:03 EST
Created attachment 689587 [details]
File: environ
Comment 6 Bob Clayton 2013-01-29 01:37:05 EST
Created attachment 689588 [details]
File: limits
Comment 7 Bob Clayton 2013-01-29 01:37:07 EST
Created attachment 689589 [details]
File: maps
Comment 8 Bob Clayton 2013-01-29 01:37:09 EST
Created attachment 689590 [details]
File: open_fds
Comment 9 Bob Clayton 2013-01-29 01:37:10 EST
Created attachment 689591 [details]
File: proc_pid_status
Comment 10 Bob Clayton 2013-01-29 01:37:12 EST
Created attachment 689592 [details]
File: var_log_messages
Comment 11 Petr Hracek 2013-01-30 02:51:11 EST
Hello Bob,

I have created thread in bacula bug report database (http://bugs.bacula.org/view.php?id=1981#c6595)
Comment 12 Petr Hracek 2013-02-04 08:19:06 EST
BugFix is corrected so that instead of generation segmentation fault
SIGABRT is generated.

Step to test that fix:
1) run command /usr/sbin/bat -c /etc/bacula/bat.conf on the system where is NOT configured BACULA.
2) When you receive message "bat: ABORT due to ERROR in console/console.cpp:157 Failed to connect to bacula-dir for populateLists"
then program have to finished with return code but NOT with segmentation fault
3) Return code should be 2

SCM:
http://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20130204/941885.html
Comment 13 Fedora Update System 2013-02-04 08:20:32 EST
bacula-5.2.12-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bacula-5.2.12-7.fc18
Comment 15 Fedora Update System 2013-02-04 09:36:33 EST
bacula-5.2.12-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/bacula-5.2.12-7.fc17
Comment 16 Fedora Update System 2013-02-04 21:58:04 EST
Package bacula-5.2.12-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bacula-5.2.12-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1906/bacula-5.2.12-7.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-02-15 19:52:37 EST
bacula-5.2.12-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-02-15 19:55:35 EST
bacula-5.2.12-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.