Bug 90562 - system init script fails to load dvorak & azerty keymaps
Summary: system init script fails to load dvorak & azerty keymaps
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
: 89211 100514 103518 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-09 17:16 UTC by Gwenn Englebienne
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version: 1.08-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-25 16:57:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gwenn Englebienne 2003-05-09 17:16:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
"loadkeys dvorak" or "loadkeys azerty" fails because the name of the .map.gz
file is the same as the directory the file is located in. e.g. dvorak.map.gz is
located in .../dvorak/dvorak.map.gz


Version-Release number of selected component (if applicable):
1.08-4

How reproducible:
Always

Steps to Reproduce:
1. Select dvorak in the keyboard layout
2. use the text-mode console (in X everythin's fine)


Actual Results:  The keyboards ends up in qwerty

Expected Results:  I would have liked to be able to type my login passwd in the
layout of my keyboard

Additional info:

The solution is either to rename the directory (e.g. .../dvorak.d/dvorak.map.gz)
or to append '.map' to the parameter of loadkeys (e.g loadkeys dvorak.map) in
the configuration script:

loadkeys $KEYTABLE < /dev/tty0 > /dev/null 2>&1

becomes

loadkeys ${KEYTABLE}.map < /dev/tty0 > /dev/null 2>&1

Comment 1 Eido Inoue 2003-07-25 16:56:00 UTC
*** Bug 100514 has been marked as a duplicate of this bug. ***

Comment 2 Eido Inoue 2003-07-25 16:57:04 UTC
the ".map" extension is now added to the parameter within the init script

Comment 3 Eido Inoue 2003-07-25 18:58:27 UTC
*** Bug 89211 has been marked as a duplicate of this bug. ***

Comment 4 Paul Morgan 2003-09-01 19:08:30 UTC
*** Bug 103518 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.