Bug 90568 - any java applet causes browser to crash since up2date
Summary: any java applet causes browser to crash since up2date
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-09 18:26 UTC by guy fulton
Modified: 2016-11-24 15:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-02 05:45:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description guy fulton 2003-05-09 18:26:47 UTC
Description of problem:java applet causes mozilla to crash 
after up2date kernel 2.4.20-9.i686 and glibc-2.3.2-27.9.i686 several programs
would not work, wine, Realplayer, StarOffice, Sun Java, etc., that worked before
the update. Replacing glibc.*.i686 with glibc.*.i386, All the programs started
working again, except java.    

Version-Release number of selected component (if applicable):initial release
RedHat 9.0


How reproducible:


Steps to Reproduce:
1.update to kernel-2.4.20-9*i686 glibc-2.3.2-27.9*i686 
2.download and install SunJava 1.4.1
3.logon a website that uses java-applet
    
Actual results:browser crashes, mozilla and Netscape 7.02


Expected results:


Additional info:

Comment 1 Andre 2003-06-25 21:17:25 UTC
I can confirm that with glibc-2.3.2-27.9 (i686) and kernel-2.4.20-18.9 (athlon)
RealPlayer-8.0-1 no longer functions (I just upgraded to RedHat 9 with all the
lastest updates).  It seems to be hanging in a futex call:

 open("/u/andre/.RealNetworks_RealShared_00", O_RDONLY) = 3
 flock(3, LOCK_EX)                       = 0
 stat64("/u/andre/.RealNetworks_RealShared_00", {st_mode=S_IFREG|0644,
st_size=105, ...}) = 0
 futex(0x817a0f0, FUTEX_WAIT, -127, NULL <unfinished ...>

Is there a workaround for this?  Thanks - andre

Comment 2 Andre 2003-06-25 22:05:14 UTC
Ooops.  I should RTFM.  Using LD_ASSUME_KERNEL=2.4.1 seems to work.

Comment 3 Ulrich Drepper 2003-10-02 05:45:52 UTC
Repeat after bugzilla reload:

This is the expected behavior.  Old JREs don't work with NPTL.  Only Sun's 1.4.2
JRE works so far, more to come in the future.  No bug.


Note You need to log in before you can comment on or make changes to this bug.