Bug 905858 - [RFE] Installer should ask whether to set up remote access and r/o user in the history database
[RFE] Installer should ask whether to set up remote access and r/o user in th...
Status: CLOSED DUPLICATE of bug 737598
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.1
Unspecified Unspecified
high Severity medium
: ---
: 3.3.0
Assigned To: Moran Goldboim
Pavel Stehlik
integration
: FutureFeature
Depends On:
Blocks: 737598 975620 978236 978237 978238
  Show dependency treegraph
 
Reported: 2013-01-30 05:32 EST by Dan Yasny
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-09 08:17:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgrinber: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2013-01-30 05:32:55 EST
Description of problem:

When DWH and reports are installed, external access may be required, as described in https://bugzilla.redhat.com/show_bug.cgi?id=875500

Besides, for external polling we should set up a readonly user in the database automatically.


Requirements:
Installer reaching the database user/password settings
- Would you like to configure the database for remote access? (configure pg_hba accordingly, and if a "yes" is chosen here...)
- Would you like to configure a read-only database user:
- Username
- Password
(run the GRANT SELECT ON ... procedure here)


In case of remoteDB:
- no need to ask for remote access confirmation
- spew out something like:
If a read-only user access is required please run the following in your remote Database:
- command to create new user and set up password
- command to grant readonly privileges on the history db tables
Comment 1 Andrew Cathrow 2013-02-28 11:50:20 EST
We should also provide a script in dbscripts for 3.3 to allow a customer to create a r/o user on an existing installation.
Comment 2 Itamar Heim 2013-06-09 08:17:22 EDT

*** This bug has been marked as a duplicate of bug 737598 ***

Note You need to log in before you can comment on or make changes to this bug.