Bug 905903 - Ajax notifications for success of actions should disappear after a set amount of time rather than require you to manually close
Ajax notifications for success of actions should disappear after a set amount...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Unspecified
medium Severity low
: snapshot1
: 3.0
Assigned To: Julie Pichon
Nir Magnezi
: Improvement, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 07:44 EST by Perry Myers
Modified: 2015-02-15 17:02 EST (History)
5 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.1-1.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 11:04:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1144820 None None None Never
OpenStack gerrit 23767 None None None Never

  None (edit)
Description Perry Myers 2013-01-30 07:44:17 EST
Description of problem:
The ajax notifications that pop up on the top left corner of Horizon when you take an action tend to stick around forever until you close them manually which is a bit annoying.

Having a timeout (say 5 seconds) would seem to be better user experience wise
Comment 1 Yaniv Kaul 2013-01-30 08:40:13 EST
I wouldn't want failures to disappear so fast.
For example, right now for some elusive reason, my horizon can't fetch
quotas. I get the red dialog every time.
But I think it's OK - I don't need the green success to remain, but
errors should be explicitly dismissed.

Success messages are fine. Changed title accordingly.
Comment 2 Matthias Runge 2013-05-15 03:54:34 EDT
I think, we need some docs for this.

It is already included in Grizzly, the behaviour is configurable:
(in local_settings.py, i.e. /etc/openstack-dashboard/local_settings)
HORIZON_CONFIG = {
...
    'auto_fade_alerts': {
        'delay': 3000,
        'fade_duration': 1500,
        'types': ['alert-success', 'alert-info']
    },
...
}
Comment 4 Nir Magnezi 2013-05-22 08:34:27 EDT
Verified NVR: python-django-horizon-2013.1.1-1.el6ost.noarch

Tested both Error and success:

ERROR: 
======
Exceeded my tenant quota, the error did not disappear till I closed it myself. 

Error: Quota exceeded for cores: Requested 4, but already used 17 of 20 cores (HTTP 413) (Request-ID: req-0a4f2474-407e-4561-adda-e9b9d38fc9d4)

Error: Unable to launch instance named "test".


Success:
========
Launched an instance, The pop-up disappeared after 5 seconds

Success: Launched instance named "test".
Comment 6 errata-xmlrpc 2013-05-29 11:04:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0878.html

Note You need to log in before you can comment on or make changes to this bug.