Bug 905937 - In Horizon UI for instance creation/launch, default to selecting a keypair to use if the user only has a single keypair available
In Horizon UI for instance creation/launch, default to selecting a keypair to...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
medium Severity low
: snapshot4
: 2.1
Assigned To: Julie Pichon
Nir Magnezi
: Improvement, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 09:19 EST by Perry Myers
Modified: 2015-02-15 17:02 EST (History)
4 users (show)

See Also:
Fixed In Version: python-django-horizon-2012.2.3-3.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 15:05:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1125124 None None None Never
OpenStack gerrit 21966 None None None Never
OpenStack gerrit 22351 None None None Never

  None (edit)
Description Perry Myers 2013-01-30 09:19:40 EST
Description of problem:
Since keypair selection is in a different tab, it's quite easy for a user to forget to manually select a keypair even in the case where he/she only has a single keypair imported

Since an image without a keypair imported is of limited usefulness, we should probably autoselect a keypair rather than forcing the user to manually go to that tab and select

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Nir Magnezi 2013-03-04 05:40:50 EST
Verified NVR: python-django-horizon-2012.2.3-5.el6ost.noarch

Created a Key-pair (Skip if you already have one):
1. Browse to: http://<host>/dashboard/nova/access_and_security/
2. Click Create Keypair

Launch an Instance:
1. Browse to: http://<host>/dashboard/nova/instances/
2. Click Launch Instance
3. Select An Image, insert a Name and choose a Flavor.
4. Click Access & Security tab
5. Verify that the Keypair Dropdown box is already populated with the Keypair name.
6. Click Launch
7. Verify that the column Keypair contains the Keypair name.
Comment 5 errata-xmlrpc 2013-03-21 15:05:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html

Note You need to log in before you can comment on or make changes to this bug.