Bug 906185 - kvm is not enabled by default on rhel7 qemu-kvm, but it is on rhel6 one otherwise
kvm is not enabled by default on rhel7 qemu-kvm, but it is on rhel6 one other...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
: 919364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 00:16 EST by Chao Yang
Modified: 2014-06-17 23:21 EDT (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-1.4.0-3.el7.x86_64.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:54:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chao Yang 2013-01-31 00:16:35 EST
Description of problem:
1. Boot a rhel7 qemu-kvm without -enable-kvm
2. Boot a rhel6 qemu-kvm without -enable-kvm

with rhel6 qemu-kvm:
/usr/libexec/qemu-kvm -monitor stdio
VNC server running on `::1:5900'
QEMU 0.12.1 monitor - type 'help' for more information
(qemu) info kvm 
kvm support: enabled


with rhel7.0. /usr/libexec/qemu-kvm -monitor stdio -vnc :10
QEMU 1.3.0 monitor - type 'help' for more information
(qemu) info kvm 
kvm support: disabled


booting withouth -enable-kvm would result in qemu-kvm coredump:
/usr/libexec/qemu-kvm -M q35 -monitor stdio -drive file=/home/RHEL-Server-6.4-64-virtio.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0 -vnc :1 -m 2048 -smp 2 -net none -vga cirrus -boot c
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffae998700 (LWP 24962)]
[New Thread 0x7fffadf96700 (LWP 24963)]
[New Thread 0x7fffaca73700 (LWP 24964)]
QEMU 1.3.0 monitor - type 'help' for more information
(qemu) 
Program received signal SIGUSR1, User defined signal 1.
[Switching to Thread 0x7fffadf96700 (LWP 24963)]
helper_stb_mmu (env=0x55555664d200, addr=1003745, val=114 'r', mmu_idx=0) at /usr/src/debug/qemu-1.3.0/softmmu_template.h:291
291	        tlb_fill(env, addr, 1, mmu_idx, retaddr);

(gdb) bt
#0  helper_stb_mmu (env=0x55555664d200, addr=1003745, val=114 'r', mmu_idx=0) at /usr/src/debug/qemu-1.3.0/softmmu_template.h:291
#1  0x00007fffcc99e036 in code_gen_buffer ()
#2  0x000055555577375e in cpu_x86_exec (env=env@entry=0x55555664d200) at /usr/src/debug/qemu-1.3.0/cpu-exec.c:599
#3  0x000055555577519e in tcg_cpu_exec (env=0x55555664d200) at /usr/src/debug/qemu-1.3.0/cpus.c:1115
#4  tcg_exec_all () at /usr/src/debug/qemu-1.3.0/cpus.c:1148
#5  qemu_tcg_cpu_thread_fn (arg=<optimized out>) at /usr/src/debug/qemu-1.3.0/cpus.c:841
#6  0x00007ffff6272d15 in start_thread () from /lib64/libpthread.so.0
#7  0x00007ffff2bba2cd in clone () from /lib64/libc.so.6



Version-Release number of selected component (if applicable):
qemu-kvm-1.3.0-3.el7.x86_64
seabios-1.7.2-0.2.gita810e4e7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Paolo Bonzini 2013-03-07 08:29:39 EST
In rawhide, qemu-kvm is a script that does

exec /usr/bin/qemu-system-x86_64 -machine accel=kvm "$@"

We need to instead patch vl.c to have the default accelerator "kvm:tcg" instead of "tcg", the same as in RHEL6.  It would be nice to have that patch upstream though.  Then Fedora could even drop the qemu-kvm script altogether.
Comment 3 Miroslav Rezanina 2013-04-23 05:42:50 EDT
Fixed in qemu-kvm-1.4.0-3.el7.x86_64.rpm
Comment 4 Hai Huang 2013-08-08 13:46:49 EDT
*** Bug 919364 has been marked as a duplicate of this bug. ***
Comment 6 mazhang 2014-01-16 01:52:25 EST
Reproduce this bug with qemu-img-1.3.0-3.el7.x86_64.

Host:
qemu-kvm-1.3.0-3.el7.x86_64
ipxe-roms-qemu-20130517-2.gitc4bce43.el7.noarch
qemu-img-1.3.0-3.el7.x86_64
qemu-kvm-tools-1.3.0-3.el7.x86_64
qemu-kvm-common-1.3.0-3.el7.x86_64
qemu-kvm-debuginfo-1.3.0-3.el7.x86_64
kernel-3.7.0-0.36.el7.x86_64

Steps:
1. Check kvm status.
[root@localhost qemu-kvm-1.3.0-3.el7]# /usr/libexec/qemu-kvm -monitor stdio -vnc :10
QEMU 1.3.0 monitor - type 'help' for more information
(qemu) info kvm
kvm support: disabled

2. Start qemu-kvm without "-enable-kvm", qemu-kvm core dumped.

(gdb) r -M pc -monitor stdio -drive file=/home/rhel6u5.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0 -vnc :1 -m 2048 -smp 2 -net none -vga cirrus -boot c
Starting program: /usr/libexec/qemu-kvm -M pc -monitor stdio -drive file=/home/rhel6u5.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0 -vnc :1 -m 2048 -smp 2 -net none -vga cirrus -boot c
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffae97c700 (LWP 2531)]
[New Thread 0x7fffadf7a700 (LWP 2532)]
[New Thread 0x7fffacb5f700 (LWP 2533)]
QEMU 1.3.0 monitor - type 'help' for more information
(qemu) 
Program received signal SIGUSR1, User defined signal 1.
[Switching to Thread 0x7fffadf7a700 (LWP 2532)]
0x0000555555867b79 in tcg_liveness_analysis (s=s@entry=0x5555564b0820 <tcg_ctx>)
    at /usr/src/debug/qemu-1.3.0/tcg/tcg.c:1426
1426	                    if (dead_temps[arg]) {
Missing separate debuginfos, use: debuginfo-install SDL-1.2.15-4.el7.x86_64 alsa-lib-1.0.26-2.el7.x86_64 bluez-libs-4.101-6.el7.x86_64 brlapi-0.5.6-12.el7.x86_64 celt051-0.5.1.3-5.el7.x86_64 cyrus-sasl-lib-2.1.23-37.el7.x86_64 cyrus-sasl-md5-2.1.23-37.el7.x86_64 cyrus-sasl-plain-2.1.23-37.el7.x86_64 dbus-libs-1.6.8-3.el7.x86_64 flac-libs-1.2.1-12.20121204gita43f56.el7.x86_64 glib2-2.34.2-1.el7.x86_64 glibc-2.16-29.el7.x86_64 gnutls-2.12.21-2.el7.x86_64 gsm-1.0.13-7.el7.x86_64 json-c-0.10-2.el7.x86_64 keyutils-libs-1.5.5-3.el7.x86_64 krb5-libs-1.10.3-11.el7.x86_64 libICE-1.0.8-2.el7.x86_64 libSM-1.2.1-2.el7.x86_64 libX11-1.5.0-3.el7.x86_64 libXau-1.0.6-4.el7.x86_64 libXext-1.3.1-2.el7.x86_64 libXi-1.6.1-2.el7.x86_64 libXtst-1.2.1-3.el7.x86_64 libaio-0.3.109-9.el7.x86_64 libasyncns-0.8-4.el7.x86_64 libcom_err-1.42.6-2.el7.x86_64 libcurl-7.27.0-6.el7.x86_64 libdb-5.3.21-3.el7.x86_64 libgcc-4.7.2-8.el7.x86_64 libgcrypt-1.5.0-9.el7.x86_64 libgpg-error-1.10-3.el7.x86_64 libidn-1.26-1.el7.x86_64 libjpeg-turbo-1.2.1-4.el7.x86_64 libogg-1.3.0-2.el7.x86_64 libpng-1.5.13-1.el7.x86_64 libseccomp-1.0.1-0.el7.x86_64 libselinux-2.1.13-3.el7.x86_64 libsndfile-1.0.25-4.el7.x86_64 libssh2-1.4.3-1.el7.x86_64 libtasn1-2.14-1.el7.x86_64 libuuid-2.22.1-2.4.el7.x86_64 libvorbis-1.3.3-3.el7.x86_64 libxcb-1.9-1.el7.x86_64 ncurses-libs-5.9-7.20121017.el7.x86_64 nspr-4.9.4-1.el7.x86_64 nss-3.14.1-3.el7.x86_64 nss-softokn-freebl-3.14-5.el7.x86_64 nss-util-3.14.1-2.el7.x86_64 openldap-2.4.33-3.el7.x86_64 openssl-libs-1.0.1c-9.el7.x86_64 p11-kit-0.14-1.el7.x86_64 pcre-8.32-4.el7.x86_64 pixman-0.26.2-5.el7.x86_64 pulseaudio-libs-2.1-5.el7.x86_64 spice-server-0.12.2-1.el7.x86_64 tcp_wrappers-libs-7.6-70.el7.x86_64 usbredir-0.6-1.el7.x86_64 zlib-1.2.7-9.el7.x86_64
(gdb) bt
#0  0x0000555555867b79 in tcg_liveness_analysis (s=s@entry=0x5555564b0820 <tcg_ctx>)
    at /usr/src/debug/qemu-1.3.0/tcg/tcg.c:1426
#1  0x000055555586c166 in tcg_gen_code_common (search_pc=-1, gen_code_buf=
    0x7fffcc9a8650 <code_gen_buffer+177744> "", s=0x5555564b0820 <tcg_ctx>)
    at /usr/src/debug/qemu-1.3.0/tcg/tcg.c:2230
#2  tcg_gen_code (s=s@entry=0x5555564b0820 <tcg_ctx>, gen_code_buf=0x7fffcc9a8650 <code_gen_buffer+177744> "")
    at /usr/src/debug/qemu-1.3.0/tcg/tcg.c:2345
#3  0x000055555586cd0b in cpu_x86_gen_code (env=env@entry=0x55555664d800, tb=tb@entry=0x7fffae98de88, 
    gen_code_size_ptr=gen_code_size_ptr@entry=0x7fffadf79aa4) at /usr/src/debug/qemu-1.3.0/translate-all.c:87
#4  0x000055555577c66f in tb_gen_code (env=env@entry=0x55555664d800, pc=pc@entry=2147369667, cs_base=cs_base@entry=
    0, flags=180, cflags=cflags@entry=0) at /usr/src/debug/qemu-1.3.0/exec.c:1068
#5  0x0000555555773a36 in tb_find_slow (flags=<optimized out>, cs_base=0, pc=2147369667, env=0x55555664d800)
    at /usr/src/debug/qemu-1.3.0/cpu-exec.c:125
#6  tb_find_fast (env=0x55555664d800) at /usr/src/debug/qemu-1.3.0/cpu-exec.c:152
#7  cpu_x86_exec (env=env@entry=0x55555664d800) at /usr/src/debug/qemu-1.3.0/cpu-exec.c:567
#8  0x000055555577519e in tcg_cpu_exec (env=0x55555664d800) at /usr/src/debug/qemu-1.3.0/cpus.c:1115
#9  tcg_exec_all () at /usr/src/debug/qemu-1.3.0/cpus.c:1148
#10 qemu_tcg_cpu_thread_fn (arg=<optimized out>) at /usr/src/debug/qemu-1.3.0/cpus.c:841
#11 0x00007ffff6271d15 in start_thread () from /lib64/libpthread.so.0
#12 0x00007ffff2bb646d in clone () from /lib64/libc.so.6


Verify this bug with qemu-kvm-1.5.3-36.el7.x86_64.

1. Check kvm status.
[root@localhost home]# /usr/libexec/qemu-kvm -monitor stdio -vnc :10
QEMU 1.5.3 monitor - type 'help' for more information
(qemu) info kvm
kvm support: enabled

2. Start qemu-kvm without "-enable-kvm", qemu-kvm not core dumped, guest works well.

(gdb) r -M pc -monitor stdio -drive file=/home/rhel6u6-64.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0 -vnc :1 -m 2048 -smp 2 -net none -vga cirrus -boot c
Starting program: /usr/libexec/qemu-kvm -M pc -monitor stdio -drive file=/home/rhel6u6-64.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0 -vnc :1 -m 2048 -smp 2 -net none -vga cirrus -boot c
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
QEMU 1.5.3 monitor - type 'help' for more information
(qemu) [New Thread 0x7fffebda4700 (LWP 3682)]
(qemu) info [New Thread 0x7fff5afff700 (LWP 3687)]
[New Thread 0x7fff5a7fe700 (LWP 3688)]
info kvm
kvm support: enabled

So this bug has been fixed.
Comment 8 Ludek Smid 2014-06-13 08:54:36 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.