Bug 90622 - description for lisa daemon isn't useful...
description for lisa daemon isn't useful...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-services (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-11 05:25 EDT by Michele Ginestra
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-16 15:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing the bug (76.73 KB, image/png)
2003-05-27 14:48 EDT, Michele Ginestra
no flags Details
the lisa daemon description found on my system (842 bytes, application/zip)
2003-05-27 14:50 EDT, Michele Ginestra
no flags Details

  None (edit)
Description Michele Ginestra 2003-05-11 05:25:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Virgilio6pc)

Description of problem:
the description for the lisa daemon isn't very useful:
"LISa is a small daemon which is intended to run on "


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. n/a
2. 
3.
    

Additional info:
Comment 1 Ngo Than 2003-05-19 11:39:00 EDT
Hmm, where did you see this description? It looks like that
the description was not correct displayed.

I have take a look in /etc/init.d/lisa. The description is correct!
And redhat-config-services also shows it correct!
Comment 2 Michele Ginestra 2003-05-20 16:08:59 EDT
the /etc/init.d/lisa file is correct, however redhat-config-services doesn't
show it correctly. if you want i can send you a screenshot.
Comment 3 Ngo Than 2003-05-23 11:43:59 EDT
strange, redhat-config-services shows it correctly for me!

could you please send the screenshot?
Comment 4 Daniel Walsh 2003-05-27 10:18:07 EDT
Is there a missing continuation line in the /etc/init.d/lisa description. 
Basically redhat-config-services reads the init scripts for the descriptions of
the service.  If someone has modified the lisa script the description can become
distorted.

Dan
Comment 5 Michele Ginestra 2003-05-27 14:48:00 EDT
Created attachment 92005 [details]
screenshot showing the bug
Comment 6 Michele Ginestra 2003-05-27 14:50:38 EDT
Created attachment 92006 [details]
the lisa daemon description found on my system
Comment 7 Daniel Walsh 2003-05-27 15:15:49 EDT
The problem is that the lisa startup script description does not have the
continuation lines.  The following patch would fix it.  I will see about getting
this patch into the next release.

--- /etc/init.d/lisa	2003-02-24 18:20:08.000000000 -0500
+++ lisa	2003-05-27 15:14:50.707853560 -0400
@@ -3,11 +3,11 @@
 # Startup script for LISa
 #
 # chkconfig: - 92 36
-# description: LISa is a small daemon which is intended to run on 
-#              end user systems. It provides something like a 
-#              "network neighbourhood", but only relying on the TCP/IP 
-#              protocol stack, no smb or whatever.
-#              The information about the hosts in your "neighbourhood" 
+# description: LISa is a small daemon which is intended to run on \
+#              end user systems. It provides something like a \
+#              "network neighbourhood", but only relying on the TCP/IP \
+#              protocol stack, no smb or whatever.\
+#              The information about the hosts in your "neighbourhood" \
 #              is provided via TCP port 7741.
 # processname: lisa
 # config: /etc/lisarc
Comment 8 Daniel Walsh 2003-06-16 15:34:13 EDT
Currently fixed in kdenetwork-3.1.2-3.src.rpm


Dan

Note You need to log in before you can comment on or make changes to this bug.