Bug 90635 - Installer says "Partition table is unexpected type loop"
Installer says "Partition table is unexpected type loop"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-11 13:57 EDT by Pavan
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 15:08:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The 1st 1kB of the hard-disk with SBM installed. (1.00 KB, application/octet-stream)
2003-05-20 13:33 EDT, Pavan
no flags Details

  None (edit)
Description Pavan 2003-05-11 13:57:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3) Gecko/20030312

Description of problem:
When trying to upgrade my RH8 installation to RH9, after I choose manually
partition with disk-druid, I get the following message

"The partition table on device /dev/hda is of unexpected type loop for your
architecture. Do you want to reinitialize the drive?"

/dev/hda6  is the /home & /dev/hda7 is the / of my RH8 installation.

My partition table looks like

Disk /dev/hda: 255 heads, 63 sectors, 3737 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       261   2096451    b  Win95 FAT32
/dev/hda2           262       522   2096482+  83  Linux
/dev/hda3           523       783   2096482+   7  HPFS/NTFS
/dev/hda4           784      3737  23728005    f  Win95 Ext'd (LBA)
/dev/hda5           784       817    273073+  82  Linux swap
/dev/hda6           818       881    514048+  83  Linux
/dev/hda7           882      1263   3068383+  83  Linux
/dev/hda8          1264      1645   3068383+  83  Linux
/dev/hda9          1646      2691   8401963+   c  Win95 FAT32 (LBA)
/dev/hda10         2692      3737   8401963+   c  Win95 FAT32 (LBA)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from cd
2.choose custom installation
3.choose manual partition
    

Actual Results:  partitions are not visible after the error message.

Additional info:
Comment 1 Michael Fulbright 2003-05-12 14:47:34 EDT
This would be something related to parted.
Comment 2 Pavan 2003-05-19 13:08:39 EDT
The output of parted /dev/hda print on the console provided by the installer
shows this
-------------------------------------------------
Disk geometry for /dev/hda: 0.000-29314.687 megabytes
Disk label type: loop
Minor    Start       End     Filesystem  Flags
1          0.000  29314.687  fat16       

Information: Don't forget to update /etc/fstab, if necessary.
-------------------------------------------------

I've Smart Boot Manager installed on my disk and that seems to be the problem.
When I remove SBM, parted recognises the partitions correctly. RH8 parted does
not have this problem.
Comment 3 Matt Wilson 2003-05-19 14:04:37 EDT
can you copy off the first 1024 bytes of your hard drive when Smart Boot Manager
is installed with:

dd if=/dev/hda of=part bs=1024 count=1

and attach it?
Comment 4 Pavan 2003-05-20 13:33:52 EDT
Created attachment 91832 [details]
The 1st 1kB of the hard-disk with SBM installed.

IIRC, SBM installs in the 1st 32kB of the hard-disk which is generally unused.
Also the SBM-parted problem seems to be reproducible on atleast one another
system I tried.
Comment 5 Matt Wilson 2003-05-20 14:12:10 EDT
great info.  I'll have a look.
Comment 6 Thomas Gebert 2004-03-11 11:03:02 EST
I have the same problem upgrading a RH 7.1 / RH 8.0 to Fedora Core 1.
But my configuration is quite different :
                                                                     
                    
The disk the installer complains about is /dev/sdb1, which is part
of a software raid device /dev/md0.
                                                                     
                    
An upgrade from RH 7.1 to RH 8.0 was possible, but not to Fedora Core 1
and it's the same from RH 8.0 to Fedora.
                                                                     
                    
My /etc/raidtab :
                                                                     
                    
raiddev             /dev/md0
raid-level                  0
nr-raid-disks               3
chunk-size                  64k
persistent-superblock       1
#nr-spare-disks     0
    device          /dev/sdb1
    raid-disk     0
    device          /dev/sdc1
    raid-disk     1
    device          /dev/sdd3
    raid-disk     2
                                                                     
                    
And a fdisk -l /dev/sdb shows :
                                                                     
                    
Disk /dev/sdb: 42 heads, 61 sectors, 1023 cylinders
Units = cylinders of 2562 * 512 bytes
                                                                     
                    
   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1             1      1023   1310432+  fd  Linux raid autodetect

The other partitions, which are part of the raid device, are
also of type "fd  Linux raid". This RH installation is the only
installation on this system (no other OS).
                                                                     
                    
What is the problem here ?

Note You need to log in before you can comment on or make changes to this bug.