Bug 906368 - ovirt-engine-backend [Scalability]:Problematic query 'getallfromvms' causes user portal to become stuck after user login.
ovirt-engine-backend [Scalability]:Problematic query 'getallfromvms' causes u...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 All
urgent Severity medium
: ---
: 3.1.3
Assigned To: Yair Zaslavsky
vvyazmin@redhat.com
infra
: Reopened, VerifiedOnDev, ZStream
Depends On: 880969
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 09:15 EST by Idith Tal-Kohen
Modified: 2016-02-10 14:34 EST (History)
23 users (show)

See Also:
Fixed In Version: si27
Doc Type: Bug Fix
Doc Text:
Previously, certain backend calls would sometimes cause environments with a high number of virtual machines and users to lock up the user portal, regardless of how many virtual machines were allocated to the individual user. Now, the calls have been organised more efficiently to prevent scaling issues.
Story Points: ---
Clone Of: 880969
Environment:
Last Closed: 2013-03-12 10:28:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Yaniv Kaul 2013-02-04 07:41:18 EST
ACK, although:
QE won't be able to verify if there is improvement same as they didn't do it for the current bug - verification here will be just that user portal logins do work in a setup with reasonable amount of VMs.
Comment 4 Leonid Natapov 2013-03-06 16:46:25 EST
si27. Tested with 1000 VMs and user with 'UserVmManager' role As System Permission. User can log into user portal and see all 1000 VMs.
Comment 8 errata-xmlrpc 2013-03-12 10:28:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0557.html

Note You need to log in before you can comment on or make changes to this bug.