Bug 906565 - [abrt] policycoreutils-python-2.1.13-27.1.fc17: __init__.py:22:swig_import_helper:ImportError: /usr/lib64/python2.7/site-packages/selinux/_selinux.so: undefined symbol: matchpathcon_init_prefixes
[abrt] policycoreutils-python-2.1.13-27.1.fc17: __init__.py:22:swig_import_he...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
abrt_hash:b5255d29a9ded6cc0aaf73c3f6d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 17:25 EST by Shyam Iyer
Modified: 2015-04-28 00:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 10:59:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.17 KB, text/plain)
2013-01-31 17:25 EST, Shyam Iyer
no flags Details
File: core_backtrace (536 bytes, text/plain)
2013-01-31 17:25 EST, Shyam Iyer
no flags Details
File: environ (2.92 KB, text/plain)
2013-01-31 17:26 EST, Shyam Iyer
no flags Details
File: smolt_data (3.35 KB, text/plain)
2013-01-31 17:26 EST, Shyam Iyer
no flags Details

  None (edit)
Description Shyam Iyer 2013-01-31 17:25:53 EST
Description of problem:
Running system-config-kickstart causes this issue.

Version-Release number of selected component:
policycoreutils-python-2.1.13-27.1.fc17

Additional info:
dso_list:       libselinux-python-2.1.10-3.fc17.x86_64
executable:     /usr/bin/audit2allow
kernel:         3.6.11-1.fc17.x86_64
uid:            1000

Truncated backtrace:
__init__.py:22:swig_import_helper:ImportError: /usr/lib64/python2.7/site-packages/selinux/_selinux.so: undefined symbol: matchpathcon_init_prefixes

Traceback (most recent call last):
  File "/usr/bin/audit2allow", line 23, in <module>
    import sepolgen.audit as audit
  File "/usr/lib64/python2.7/site-packages/sepolgen/audit.py", line 20, in <module>
    import refpolicy
  File "/usr/lib64/python2.7/site-packages/sepolgen/refpolicy.py", line 22, in <module>
    import selinux
  File "/usr/lib64/python2.7/site-packages/selinux/__init__.py", line 26, in <module>
    _selinux = swig_import_helper()
  File "/usr/lib64/python2.7/site-packages/selinux/__init__.py", line 22, in swig_import_helper
    _mod = imp.load_module('_selinux', fp, pathname, description)
ImportError: /usr/lib64/python2.7/site-packages/selinux/_selinux.so: undefined symbol: matchpathcon_init_prefixes

Local variables in innermost frame:
fp: <closed file '/usr/lib64/python2.7/site-packages/selinux/_selinux.so', mode 'rb' at 0x7fd58df23030>
imp: <module 'imp' (built-in)>
dirname: <function dirname at 0x7fd594416500>
pathname: '/usr/lib64/python2.7/site-packages/selinux/_selinux.so'
description: ('.so', 'rb', 3)
Comment 1 Shyam Iyer 2013-01-31 17:25:56 EST
Created attachment 691281 [details]
File: backtrace
Comment 2 Shyam Iyer 2013-01-31 17:25:58 EST
Created attachment 691282 [details]
File: core_backtrace
Comment 3 Shyam Iyer 2013-01-31 17:26:01 EST
Created attachment 691283 [details]
File: environ
Comment 4 Shyam Iyer 2013-01-31 17:26:03 EST
Created attachment 691284 [details]
File: smolt_data
Comment 5 Daniel Walsh 2013-02-01 08:13:05 EST
This looks like a libselinux issue.

rpm -q libselinux
Comment 6 Shyam Iyer 2013-02-01 10:16:36 EST
(In reply to comment #5)
> This looks like a libselinux issue.
> 
> rpm -q libselinux

Ha.. 

[shiyer@dhcp-189-205 ~]$ rpm -q libselinux
libselinux-2.1.10-3.fc17.x86_64
libselinux-2.1.10-3.fc17.i686
libselinux-2.1.12-7.fc18.x86_64

Need to uninstall one ?
Comment 7 Daniel Walsh 2013-02-01 10:59:37 EST
Something blew up.

Do an yum reinstall libselinux

It should clear it up.  Not sure you really need the i686 version, but make sure those get updated.

Note You need to log in before you can comment on or make changes to this bug.