Bug 906675 - Not all packages are signed
Not all packages are signed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-01 02:59 EST by shaochen
Modified: 2013-02-27 09:16 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 09:16:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shaochen 2013-02-01 02:59:35 EST
Description of problem:
Not all packages are signed

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130130.0.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh.
2. Verify that all packages are signed
#rpm -qa --qf '%{name}-%{version}-%{release}.%{arch} (%{SIGPGP:pgpsig})\n' | grep -v "Key ID"
3. # mount rhevh-6.4-20130130.0.0.el6.iso -o loop /mnt
4. # cat /mnt/isolinux/manifest-rpm.txt
  
Actual results:
# rpm -qa --qf '%{name}-%{version}-%{release}.%{arch} (%{SIGPGP:pgpsig})\n' | grep -v "Key ID"
vdsm-cli-4.10.2-1.2.el6.noarch ((none))
ovirt-node-2.5.0-17.el6.noarch ((none))
vdsm-4.10.2-1.2.el6.x86_64 ((none))
vdsm-hook-vhostmd-4.10.2-1.2.el6.noarch ((none))
vdsm-python-4.10.2-1.2.el6.x86_64 ((none))
vdsm-reg-4.10.2-1.2.el6.noarch ((none))
vdsm-xmlrpc-4.10.2-1.2.el6.noarch ((none))


looking at the manifest-rpm.txt in the iso image, not all packages are signed.
# cat manifest-rpm.txt | grep none
ovirt-node-2.5.0-17.el6.noarch ((none))
vdsm-4.10.2-1.2.el6.x86_64 ((none))
vdsm-cli-4.10.2-1.2.el6.noarch ((none))
vdsm-hook-vhostmd-4.10.2-1.2.el6.noarch ((none))
vdsm-python-4.10.2-1.2.el6.x86_64 ((none))
vdsm-reg-4.10.2-1.2.el6.noarch ((none))
vdsm-xmlrpc-4.10.2-1.2.el6.noarch ((none))

Expected results:
After executed that command,it should return nothing and all packages are signed

Additional info:
No such issue in rhevh-6.4-20130116.3.0.el6 version, so it is a regression bug.
Comment 4 Dennis Gregorovic 2013-02-01 08:18:47 EST
I figured out what happened.  Before the RC compose I signed the wrong tag.  So, during the compose it refused to create the image because of the unsigned packages.  I then signed the packages and created the image manually.  However, I forgot to update the paths in the repodata to point at the signed copies.  This is an easy fix.  Will get a new image out later today.

Note You need to log in before you can comment on or make changes to this bug.