Bug 906736 - Rhel7 guest(after boot up) have no response when execute 'sendkey alt-ctrl-delete'
Rhel7 guest(after boot up) have no response when execute 'sendkey alt-ctrl-de...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-01 05:22 EST by langfang
Modified: 2015-05-24 20:07 EDT (History)
14 users (show)

See Also:
Fixed In Version: QEMU-1.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:48:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description langfang 2013-02-01 05:22:18 EST
Description of problem:

Rhel7 guest have no response after 'sendkey alt-ctrl-delete'

Version-Release number of selected component (if applicable):
# uname -r
3.7.0-0.32.el7.x86_64
qemu-kvm-1.3.0-3.el7.x86_64

guest:rhel7

3.6.0-0.29.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot guest
2.(qemu)sendkey alt-ctrl-delete

Results:
Rhel7 guest have no response
  
Actual results:


Expected results:


Additional info:
1)Tried rhel6.4 guest on rhel6.4 host not hit the problem,after (qemu)sendkey alt-ctrl-delete, guest can prompt windows to inquire user if shutdown ...see attachment for rhel6.4 guest .

2)Tried other keys
(qemu)sendkey up -->work 
(qemu)sendkey down--->work
(qemu)sendkey f5-->work
3)Another problem ,After rhel7 guest boot up ,press key ctrl+al+delete ,also not response .

4)MY CLI:
/usr/libexec/qemu-kvm -M pc-1.3 -enable-kvm -m 1024 -smp 2,sockets=2,cores=1,threads=1 -uuid `uuidgen` -no-user-config -nodefaults -monitor stdio -rtc base=utc  -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/home/RHEL-Server-7.0-64-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2 -device ide-drive,bus=ide.0,unit=1,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:60:3f:29,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc :10 -vga std -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x6 -chardev socket,id=channel0,path=/tmp/tty0,server,nowait -device virtserialport,chardev=channel0,name=org.linux-kvm.port.1,bus=virtio-serial0.0,id=port1 -boot n
Comment 1 langfang 2013-02-01 05:26:38 EST
Addtional info :Tried on rhel7 host ,win7-64 guest not hit the problem.
Version:
HOST
# uname -r
3.7.0-0.32.el7.x86_64
qemu-kvm-1.3.0-3.el7.x86_64
Guest:win7-64
Comment 3 langfang 2013-02-01 05:44:47 EST
TEST NOTE:
1)Guest in the booting process---->(qemu)sendkey alt-ctrl-delete--->Guest can reboot again
2)After Guest boot up--->(qemu)sendkey alt-ctrl-delete--->Guest no response
Comment 4 Hai Huang 2013-02-11 15:33:01 EST
Problem can be easily reproduced with QEMU-KVM from Fedora 18 and RHEL7.

Additional note: the SendKey Ctrl-Alt-Delete sequence from the console 
(over spice) works as expected (i.e. initiates the shutdown sequence).

Assigning to Amos for further investigation because there some changes 
made in a couple of upstream patches in this area posted in 2012.
Comment 5 Amit Shah 2013-02-12 01:22:07 EST
This also depends on the key handling in the desktop session.  E.g. gnome might inhibit the key sequence or assign 'ctrl+alt+del' to an entirely different operation.

The only sure way to reboot or powerdown a guest is via the guest agent.
Comment 6 Amos Kong 2013-03-19 06:06:53 EDT
Langfang, can you help to test those configurations?

rhel7 guest @ qemu-kvm-rhel6 (sendkey alt-ctrl-delete)
rhel6 guest @ qemu-kvm-rhel7 (sendkey alt-ctrl-delete)
RHEL7 host (press key ctrl+al+delete)
Comment 7 Amos Kong 2013-03-19 06:21:38 EDT
(In reply to comment #6)
> Langfang, can you help to test those configurations?
>
> rhel7 guest @ qemu-kvm-rhel6 (sendkey alt-ctrl-delete)
> rhel6 guest @ qemu-kvm-rhel7 (sendkey alt-ctrl-delete)

Langfang, please help to test this scenario:
  Connect vnc, Press F8->Send Crtl+Alt+Del

> RHEL7 host (press key ctrl+al+delete)
Comment 8 langfang 2013-03-19 07:17:15 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Langfang, can you help to test those configurations?
> >
> > rhel7 guest @ qemu-kvm-rhel6 (sendkey alt-ctrl-delete)
> > rhel6 guest @ qemu-kvm-rhel7 (sendkey alt-ctrl-delete)
> 
> Langfang, please help to test this scenario:
>   Connect vnc, Press F8->Send Crtl+Alt+Del
> 


*Senario 1)rhel7 guest @ qemu-kvm-rhel6 (sendkey alt-ctrl-delete)
After guest boot up-->sendkey alt-ctrl-delete-->no response

*Senario 2)rhel7 guest @ qemu-kvm-rhel6(Press F8->Send Crtl+Alt+Del)

After guest boot up--->Press F8->Send Crtl+Alt+Del--->work OK

*Senario 3)rhel7 guest @ qemu-kvm-rhel6(Press keyboard "ctrl+alt+del")

After guest boot up ---->Press keyboard "ctrl+alt+del"--->no response

*Senario 4)rhel6 guest @ qemu-kvm-rhel7(sendkey alt-ctrl-delete)

After guest boot up-->sendkey alt-ctrl-delete-->work OK

*Senario 5)rhel6 guest @ qemu-kvm-rhel7(Press F8->Send crtl+Alt+Del)

After guest boot up--->Press F8->Send Crtl+Alt+Del--->work OK

*Senario 6)rhel6 guest @ qemu-kvm-rhel7(Press keyboard "ctrl+alt+del")

After guest boot up ---->Press keyboard "ctrl+alt+del"--->no response

> > RHEL7 host (press key ctrl+al+delete)

host --->press key ctrl+al+delete-->work OK

HOst rhel7:
# uname -r
3.8.0-0.40.el7.x86_64
# rpm -q qemu-kvm
qemu-kvm-1.4.0-1.el7.x86_64

HOst rhel6:
# uname -r
2.6.32-358.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.358.el6_4.bz909059.x86_64

Guest :rhel7: 3.8.0-0.40.el7.x86_64
Guest :rhel6: 2.6.32-343.el6.x86_64
Comment 9 xhan 2013-04-10 23:05:30 EDT
My test result for rhel6.4(guest) on qemu-kvm-rhel7  is different.

Host:
RHEL7
3.9.0-0.rc6.50.el7.x86_64
qemu-kvm-1.4.0-2.el7.x86_64

Guest:
RHEL6.4


*Senario 4)rhel6 guest @ qemu-kvm-rhel7(sendkey alt-ctrl-delete)

After guest boot up-->sendkey alt-ctrl-delete--> no reponse
Comment 14 Amos Kong 2013-04-16 09:47:30 EDT
Hi Flang,

Please report a new bug, remember to add the output of showkey to bz.

  Press keyboard "ctrl+alt+del" -->no response
Comment 15 langfang 2013-04-16 10:46:48 EDT
(In reply to comment #14)
> Hi Flang,
> 
> Please report a new bug, remember to add the output of showkey to bz.
> 
>   Press keyboard "ctrl+alt+del" -->no response


Report new bug to track  
Bug 952720 - Due to wrong key press/release order press keyboard"ctrl+alt+delete", linux guest no response


thanks
Comment 16 Amos Kong 2013-08-30 06:05:51 EDT
release event order was fixed by 
commit 153d02e338a063ad5c51ff0725d5d88285f44121
Comment 19 mazhang 2013-11-29 04:25:03 EST
Confirm with flang and akong for this bug reproduce and verification, this bug is qemu-kvm press/release order issue, this is a duplicate bug of bz949348  except comment#10 mentioned issue which has been file a new bz952720.
This bug can be verify by bz949348#c14.
Comment 21 Ludek Smid 2014-06-13 07:48:03 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.