Bug 90702 - post scriplet fails
post scriplet fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 12:43 EDT by Sepp Rudel
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 18:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sepp Rudel 2003-05-12 12:43:31 EDT
Description of problem:
While I was updating from RHL7.3->RHL9 with apt (yea, I know, not supported by
RH, but read on...), metacity gave following error:

 134:metacity               ########################################### [ 20%]
/var/tmp/rpm-tmp.41604: line 1: gconftool-2: command not found
/var/tmp/rpm-tmp.41604: line 5: gconftool-2: command not found
error: execution of %post scriptlet from metacity-2.4.34-3 failed, exit status 127

Probably caused by the fact that also RPM containing gconftool-2 was about to be
updated after metacity during the same "rpm -Uvh" run. This caused metacity to
be misconfigured. This might well happen also with up2date/rpm -Fvh/yum/etc.


Version-Release number of selected component (if applicable):
All, I presume.

How reproducible:
Always.

Steps to Reproduce:
1.update metacity and RPMs containing gconftool-2 in the same run
    
Actual results:
errors are printed.


Expected results:
no errors.


Additional info:
Probably not critical but worth fixing IMHO.
Comment 1 Havoc Pennington 2003-10-03 18:00:31 EDT
With rpm -Uvh or yum this wouldn't happen; the problem is that apt doesn't do
proper ordering of RPMs it's installing. This may be fixed in newer versions of
apt, but is one of the reasons we don't historically ship apt.

metacity depends on gconf so the information is there to know that gconf has to
be installed first, the tool just has to use it.

Note You need to log in before you can comment on or make changes to this bug.