Bug 90703 - post scriplet fails
post scriplet fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libgnomeprint (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 12:46 EDT by Sepp Rudel
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 17:51:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sepp Rudel 2003-05-12 12:46:26 EDT
Description of problem:
While I was updating from RHL7.3->RHL9 with apt (yea, I know, not supported by
RH, but read on...), libgnomeprint gave following error:

 137:libgnomeprint          ########################################### [ 20%]
/usr/bin/libgnomeprint-2.0-font-install: error while loading shared
libraries: libORBit-2.so.0: cannot open shared object file: No such file or
directory
error: execution of %post scriptlet from libgnomeprint-1.116.0-6 failed, exit
status 127

Probably caused by the fact that also RPM containing libORBit-2.so.0 was about
to be updated after pango during the same "rpm -Uvh" run. This caused
libgnomeprint to be misconfigured. This might well happen also with up2date/rpm
-Fvh/yum/etc.


Version-Release number of selected component (if applicable):
All, I presume.

How reproducible:
Always.

Steps to Reproduce:
1.update libgnomeprint and RPMs containing libORBit-2.so.0 in the same run
    
Actual results:
errors are printed.


Expected results:
no errors.


Additional info:
Probably not critical but worth fixing IMHO.
Comment 1 Owen Taylor 2003-08-28 17:51:16 EDT
See comments in other similar bug you filed - if RPM and apt are working
correctly, ORBit will be installed first and this won't happen:

 $ rpm -qp --requires
/mnt/redhat/beehive/comps/dist/8.0.1/libgnomeprint/1.116.0-6/i386/libgnomeprint-1.116.0-6.i386.rpm
 | grep ORBit

Comment 2 Sepp Rudel 2003-08-29 03:27:20 EDT
Ok. Just for reference, please bear in mind that apt only downloads needed RPMs,
they're installed in a standard RH way by apt: rpm -Uvh *rpm.

Thanks for looking into this.

Note You need to log in before you can comment on or make changes to this bug.