Bug 90704 - post scriplet fails
Summary: post scriplet fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-user-docs   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-12 17:07 UTC by Sepp Rudel
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-12 18:52:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sepp Rudel 2003-05-12 17:07:05 UTC
Description of problem:
While I was updating from RHL7.3->RHL9 with apt (yea, I know, not supported by
RH, but read on...), gnome-user-docs gave following errors:

 464:gnome-user-docs        ########################################### [ 70%]
scrollkeeper-update: warning:
/usr/share/omf/gnome-user-docs/introduction-to-gnome-C.omf overrides
/usr/share/omf/gnome2-user-docs/introduction-to-gnome-C.omf
OMF file [/usr/share/omf/gnome-user-docs/gnome-users-guide-C.omf] does not
validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register /usr/share/omf/gnome-user-docs/gnome-users-guide-C.omf
OMF file [/usr/share/omf/gnome-user-docs/glossary-C.omf] does not validate
against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register /usr/share/omf/gnome-user-docs/glossary-C.omf
OMF file [/usr/share/omf/gnome-user-docs/introduction-to-gnome-es.omf]
does not
validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register
/usr/share/omf/gnome-user-docs/introduction-to-gnome-es.omf
OMF file [/usr/share/omf/gnome-user-docs/gnome-users-guide-es.omf] does
not validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register /usr/share/omf/gnome-user-docs/gnome-users-guide-es.omf
OMF file [/usr/share/omf/gnome-user-docs/introduction-to-gnome-C.omf] does
not validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register
/usr/share/omf/gnome-user-docs/introduction-to-gnome-C.omf
OMF file [/usr/share/omf/gnome-user-docs/introduction-to-gnome-it.omf]
does not
validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register
/usr/share/omf/gnome-user-docs/introduction-to-gnome-it.omf
OMF file [/usr/share/omf/gnome-user-docs/unix-primer-C.omf] does not
validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register /usr/share/omf/gnome-user-docs/unix-primer-C.omf
OMF file [/usr/share/omf/gnome-user-docs/unix-primer-es.omf] does not
validate against ScrollKeeper-OMF DTD:
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd
Unable to register /usr/share/omf/gnome-user-docs/unix-primer-es.omf

Probably caused by the fact that also RPM containing something needed by
gnome-user-docs %post scriptlets was about to be updated after gnome-user-docs
during the same "rpm -Uvh" run. This caused gnome-user-docs to be misconfigured.
This might well happen also with up2date/rpm -Fvh/yum/etc.


Version-Release number of selected component (if applicable):
All, I presume.

How reproducible:
Always.

Steps to Reproduce:
1.update gnome-user-docs and RPMs used during %post in the same run
    
Actual results:
errors printed.


Expected results:
no errors.

Additional info:
Probably not critical but worth fixing IMHO. Not sure what RPM should be
installed after/before to prevent errors. scrollkeeper RPM was installed just
before gnome-user-docs when this happened.

Comment 1 Havoc Pennington 2003-05-12 18:52:51 UTC
This one isn't fixable, there's an old closed bug that talks about it.
Basically the old gnome-user-docs has errors and you can't retroactively 
fix them. It's pretty harmless though, other than the warning.

Comment 2 Sepp Rudel 2003-05-13 11:27:17 UTC
Yes, ok, sorry for missing that. Thanks for the fix.


Note You need to log in before you can comment on or make changes to this bug.