This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 907259 - Uploading image with no container format leaves image stuck in queued
Uploading image with no container format leaves image stuck in queued
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Bresnahan
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-03 19:36 EST by Graeme Gillies
Modified: 2013-09-29 22:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 21:20:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graeme Gillies 2013-02-03 19:36:34 EST
Hi,

When you use glance image-upload but fail to specify a container-format, the whole image gets uploaded, then it errors out (error is no container-format was specified. However, the image is still in glance in state queued which seems a bit non-sensical?

Regards,

Graeme
Comment 2 John Bresnahan 2013-02-13 21:11:57 EST
With the version of glance server from the RPM openstack-glance-2012.2.1-4.el6ost.noarch and the client from python-glanceclient-0.5.1-1.el6.noarch (what is currently in 6.4 beta) I do not experience this problem.  The image is not uploaded when the container-format argument is left out.

The entry in glance is left in the queued state because the user can still use the image-update command to set the container format and upload the image.

Note You need to log in before you can comment on or make changes to this bug.