Bug 90726 - Unable to install Perl module Net::SSLeay due to krb5.h not found
Unable to install Perl module Net::SSLeay due to krb5.h not found
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 20:07 EDT by Les Bell
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 14:15:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Les Bell 2003-05-12 20:07:51 EDT
Attempting to install Perl module Net::SSLeay from CPAN with command

perl -MCPAN -e 'install Net::SSLeay'

will fail as follows:

gcc -c  -I/usr/include -I/usr/inc32 -D_REENTRANT -D_GNU_SOURCE
-DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O  
-DVERSION=\"1.22\" -DXS_VERSION=\"1.22\" -fPIC
"-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE"  -DPERL5 SSLeay.c
In file included from /usr/include/openssl/ssl.h:179,
                 from SSLeay.xs:87:
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory
In file included from /usr/include/openssl/ssl.h:179,
                 from SSLeay.xs:87:
/usr/include/openssl/kssl.h:132: parse error before "krb5_enctype"

Version-Release number of selected component (if applicable):
krb5-devel-1.2.7-10

How reproducible:
Always

Steps to Reproduce:
1. export LANG=en_AU (to get around Bug# 90597)
2. perl -MCPAN -e 'install Net::SSLeay'
3.
    

Actual Results:  Error messages as above.

Expected Results:  Should have compiled, tested and installed cleanly.

Additional info:

The problem is that the krb5.h file is not being found as /usr/kerberos/include
is not in the compilers's INCLUDE path. I was able to manually install by
editing /root/.cpan/build/Net_SSLeay.pm-1.22/Makefile.PL line 166 to read

    INC  => "-I /usr/kerberos/include -I$openssl_path/include
-I$openssl_path/inc32",

and running ./Makefile.pl -t; make install

However, this could affect installation of other OpenSSL- or Kerberos-related code
Comment 1 Bishop Clark 2003-05-31 06:17:24 EDT
Hmm.  this looks like bug 82369 .

.. and bug 81611

I'm laying odds this isn't the last one.
Comment 2 flavio 2003-06-05 05:24:35 EDT
On redhat 9 :


You have OpenSSL-0.9.7a installed in /usr
That's is newer than what this module was tested with (0.9.6g). You should
consider checking if there is a newer release of this module
available. Everything will probably work OK, though.
*** Could not figure out which C compiler was used to 
compile /usr/bin/openssl. It is essentiall that OpenSSL, perl, and Net::SSLeay 
are compiled with the same compiler and flags. Mixing and matching compilers 
is not supported. at Makefile.PL line 132.

Warning: I could not locate your pod2man program. Please make sure,
         your pod2man program is in your PATH before you execute 'make'

Writing Makefile for Net::SSLeay::Handle

Warning: I could not locate your pod2man program. Please make sure,
         your pod2man program is in your PATH before you execute 'make'

Writing Makefile for Net::SSLeay
Comment 3 Bill Nottingham 2006-08-05 01:20:18 EDT
Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks.

Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
They are maintained by the Fedora Legacy project (http://www.fedoralegacy.org/)
for security updates only. If this is a security issue, please reassign to the
'Fedora Legacy' product in bugzilla. Please note that Legacy security update
support for these products will stop on December 31st, 2006.

If this is not a security issue, please check if this issue is still present
in a current Fedora Core release. If so, please change the product and version
to match, and check the box indicating that the requested information has been
provided.

If you are currently still running Red Hat Linux 7.3 or 9, please note that
Fedora Legacy security update support for these products will stop on December
31st, 2006. You are strongly advised to upgrade to a current Fedora Core release
or Red Hat Enterprise Linux or comparable. Some information on which option may
be right for you is available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Any bug still open against Red Hat Linux 7.3 or 9 at the end of 2006 will be
closed 'CANTFIX'. Again, if this bug still exists in a current release, or is a
security issue, please change the product as necessary. We thank you for your
help, and apologize again that we haven't handled these issues to this point.
Comment 5 Bill Nottingham 2007-01-02 14:15:56 EST
Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
f you are currently still running Red Hat Linux 7.3 or 9, you are strongly
advised to upgrade to a current Fedora Core release or Red Hat Enterprise Linux
or comparable. Some information on which option may be right for you is
available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.