Bug 90736 - After installing nVidia drivers, unable to compile glX application
After installing nVidia drivers, unable to compile glX application
Status: CLOSED DUPLICATE of bug 90734
Product: Red Hat Linux
Classification: Retired
Component: glut (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-12 23:04 EDT by Brian Hayward
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Hayward 2003-05-12 23:04:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i586; U;) Gecko/20020913

Description of problem:
When compiling a glut application after installing the nVidia drivers, I
received the following error messages:

/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXBindChannelToWindowSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXQueryChannelDeltasSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXChannelRectSyncSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXChannelRectSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXQueryChannelRectSGIX'
collect2: ld returned 1 exit status

This problem did not happen on earlier RH-OS builds when changing between the
nvidia and non-nvidia drivers.

Version-Release number of selected component (if applicable):
glut-3.7-12 and glut-devel-3.7-12

How reproducible:
Always

Steps to Reproduce:
1.Compile my development project
2.See the error
3.goto step 1
    

Actual Results:  /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so:
undefined reference to `glXBindChannelToWindowSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXQueryChannelDeltasSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXChannelRectSyncSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXChannelRectSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXQueryChannelRectSGIX'
collect2: ld returned 1 exit status

Expected Results:  A successful compile of my application.

Additional info:

Does the redhat provided glut support dynamic glX extensions?  The strange thing
is, using the SAME nvidia driver on Red Hat Linux 7.3 does not give this
problem.  If you have any tips on how to resolve this, I would appreciate it. 
Thanks,

Thanks,
Brian
Comment 1 Mike A. Harris 2003-05-13 03:59:24 EDT

*** This bug has been marked as a duplicate of 90734 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.