Bug 907653 - SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a process.
SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a pr...
Status: CLOSED DUPLICATE of bug 907657
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a44d35fa9bf915978cb2a2134ff...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 17:41 EST by maheffa
Modified: 2013-02-05 01:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 01:32:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description maheffa 2013-02-04 17:41:58 EST
Description of problem:
SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that Xorg should be allowed getpgid access on processes labeled xdm_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Objects                 [ process ]
Source                        Xorg
Source Path                   /usr/bin/Xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.13.2-1.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-73.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.7.4-204.fc18.i686 #1 SMP Wed Jan
                              23 17:08:59 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-02-05 06:37:37 MSK
Last Seen                     2013-02-05 06:37:37 MSK
Local ID                      80d2a23c-a3a0-4da6-906a-0382beb330ef

Raw Audit Messages
type=AVC msg=audit(1360031857.281:198): avc:  denied  { getpgid } for  pid=785 comm="Xorg" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1360031857.281:198): arch=i386 syscall=getpgid success=no exit=EACCES a0=302 a1=0 a2=8263000 a3=8267280 items=0 ppid=770 pid=785 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: Xorg,xdm_t,xdm_t,process,getpgid

audit2allow

#============= xdm_t ==============
allow xdm_t self:process getpgid;

audit2allow -R

#============= xdm_t ==============
allow xdm_t self:process getpgid;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.7.4-204.fc18.i686
type:           libreport

Potential duplicate: bug 804241
Comment 1 Miroslav Grepl 2013-02-05 01:32:12 EST

*** This bug has been marked as a duplicate of bug 907657 ***

Note You need to log in before you can comment on or make changes to this bug.