Bug 907654 - SELinux is preventing /usr/bin/Xorg from 'compromise_kernel' accesses on the capability2 .
SELinux is preventing /usr/bin/Xorg from 'compromise_kernel' accesses on the ...
Status: CLOSED DUPLICATE of bug 907657
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:72df1c8c1cebbcd3c057a9b0b9b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 17:42 EST by maheffa
Modified: 2013-02-05 01:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 01:32:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description maheffa 2013-02-04 17:42:24 EST
Description of problem:
SELinux is preventing /usr/bin/Xorg from 'compromise_kernel' accesses on the capability2 .

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that Xorg should be allowed compromise_kernel access on the  capability2 by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Objects                 [ capability2 ]
Source                        Xorg
Source Path                   /usr/bin/Xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.13.2-1.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-73.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.7.4-204.fc18.i686 #1 SMP Wed Jan
                              23 17:08:59 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-02-05 06:37:37 MSK
Last Seen                     2013-02-05 06:37:37 MSK
Local ID                      48719532-d571-4ea1-9e0c-4e43251bf371

Raw Audit Messages
type=AVC msg=audit(1360031857.282:199): avc:  denied  { compromise_kernel } for  pid=785 comm="Xorg" capability=37  scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=capability2


type=SYSCALL msg=audit(1360031857.282:199): arch=i386 syscall=ioperm success=no exit=EPERM a0=0 a1=400 a2=1 a3=1 items=0 ppid=770 pid=785 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: Xorg,xdm_t,xdm_t,capability2,compromise_kernel

audit2allow

#============= xdm_t ==============
allow xdm_t self:capability2 compromise_kernel;

audit2allow -R

#============= xdm_t ==============
allow xdm_t self:capability2 compromise_kernel;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.7.4-204.fc18.i686
type:           libreport
Comment 1 Miroslav Grepl 2013-02-05 01:32:01 EST

*** This bug has been marked as a duplicate of bug 907657 ***

Note You need to log in before you can comment on or make changes to this bug.