Bug 907859 - Eclipse failed starting up
Eclipse failed starting up
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 07:35 EST by Rafiqul Islam
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 13:40:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
It's the bundle.info of eclipse what I found in it's lib folder (22.29 KB, application/octet-stream)
2013-02-05 07:35 EST, Rafiqul Islam
no flags Details
.log file of eclipse workspace (642.81 KB, text/x-log)
2013-02-09 06:40 EST, Rafiqul Islam
no flags Details

  None (edit)
Description Rafiqul Islam 2013-02-05 07:35:47 EST
Created attachment 693356 [details]
It's the bundle.info of eclipse what I found in it's lib folder

Description of problem:
Just today I have installed it. Definitely it's not the fault of eclipse, I was greedy enough to install so many plugins. It did so well with PDT, git, web tools, and few development plugins. But after installing General Purpose Tools > Remote Service .. (I forgot what's next, sorry). It failed at start up.

Please help me how I can recover this installation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Krzysztof Daniel 2013-02-05 07:55:00 EST
Hey Rafiqul,
was there any error displayed? have you tried starting Eclipse from a console (what is displayed)? Could you find a .log file in your workspace/.metadata folder?

How were you installing all those plugins? Were you using yum? Or Eclipse Update Manager?
Comment 2 Rafiqul Islam 2013-02-09 06:38:39 EST
(In reply to comment #1)
> Hey Rafiqul,
> was there any error displayed? have you tried starting Eclipse from a
> console (what is displayed)? Could you find a .log file in your
> workspace/.metadata folder?
> 
> How were you installing all those plugins? Were you using yum? Or Eclipse
> Update Manager?

I have mailed the attached log file from .metadata of workspace folder. I don't know how to upload here.
Comment 3 Rafiqul Islam 2013-02-09 06:40:20 EST
Created attachment 695426 [details]
.log file of eclipse workspace
Comment 4 Krzysztof Daniel 2013-02-11 13:40:12 EST
Rafiqul,

it looks like you have selected another version of Eclipse on the top of your existing installation, which broke the configuration.

The only workaround is to remove the ~/.eclipse folder which undo all software installations and wipes majority of Eclipse settings.

I'm afraid I can't fix the general use case - it is how Eclipse was designed - certain updates can break Eclipse. There is some work done in Eclipse to fix this, but I'd not expect immediate results.

Note You need to log in before you can comment on or make changes to this bug.