Bug 907871 - no check prevents deletion of router interface needed by a floating ip
no check prevents deletion of router interface needed by a floating ip
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity unspecified
: snapshot3
: 2.1
Assigned To: Gary Kotton
Ofer Blaut
: Rebase, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-05 07:46 EST by Gary Kotton
Modified: 2016-04-26 18:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 10:41:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1081325 None None None Never

  None (edit)
Description Gary Kotton 2013-02-05 07:46:36 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Ofer Blaut 2013-03-11 10:50:04 EDT
already tested , can't delete router when associated ip is used 


quantum router-gateway-clear 835ffa1f-4aab-44f1-a0b6-c5292fa0ebb4
Gateway cannot be updated for router 835ffa1f-4aab-44f1-a0b6-c5292fa0ebb4, since a gateway to external network 84e146ef-da0d-4369-98d5-9217536c4794 is required by one or more floating IPs.

quantum router-delete 835ffa1f-4aab-44f1-a0b6-c5292fa0ebb4
Router 835ffa1f-4aab-44f1-a0b6-c5292fa0ebb4 still has active ports


openstack-quantum-2012.2.3-5.el6ost.noarch

Note You need to log in before you can comment on or make changes to this bug.