Bug 90815 - RH9 not working with via on-board audio
RH9 not working with via on-board audio
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-14 01:13 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 20:52:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-05-14 01:13:52 EDT
Description of problem:
AC97 via82cxxx driver not working with RH9

Version-Release number of selected component (if applicable):

How reproducible: all the time..... it never played the test sound from the
very beginning.


Steps to Reproduce:
1. Installed on via board with on board sound (shuttle AV18/e)
2. 
3.
    
Actual results:


Expected results:


Additional info:

modules.conf looks like:

alias eth0 8139too
alias usb-controller usb-uhci
alias sound-slot-0 via82cxxx_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

and in /var/log/ grep sound gives...
[root@dhcppc2 log]# grep sound messages
May 13 16:44:11 dhcppc2 modprobe: modprobe: Can't locate module sound-slot-1
May 13 16:44:11 dhcppc2 modprobe: modprobe: Can't locate module sound-service-1-0
May 13 16:44:12 dhcppc2 modprobe: modprobe: Can't locate module sound-slot-1
May 13 16:44:12 dhcppc2 modprobe: modprobe: Can't locate module sound-service-1-0
May 13 16:47:15 dhcppc2 userhelper: pam_timestamp: timestamp file
`/var/run/sudo/bsepp/unknown:root' is too old, disallowing access to
redhat-config-soundcard for UID 500
Comment 1 Isaac Salsberg 2003-11-06 19:42:14 EST
My computer is using the i810_audio module and 
I got the same error from messages, however the module apears loaded
with lsmod:

Module                  Size  Used by    Not tainted
i810_audio             27624   0  (unused)
ac97_codec             14568   0  [i810_audio]
soundcore               6404   2  [i810_audio]

Though, I can not get any sound from it.

It seems to be a pattern with this issue.
See bugs: 88586, 90286 and 92229 and probably more :-(
Comment 2 Tomas Mraz 2004-11-16 12:33:59 EST
PAM? Why PAM?

Note You need to log in before you can comment on or make changes to this bug.