Bug 9085 - Allow usage of replacement_policy in squid-2.3.STABLE1-2
Allow usage of replacement_policy in squid-2.3.STABLE1-2
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: squid (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-02 17:26 EST by Olivier Benghozi
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 12:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Benghozi 2000-02-02 17:26:53 EST
In squid 2.3-STABLE1, the cache replacement policy can be modified, to use
new and better GDSF or LFUDA policies, instead of old LRU policy.
The sample config file describes this at: TAG: replacement_policy
so we could use, by example: replacement_policy LFUDA

HOWEVER, to be able to use this interesting tag in squid.conf, a parameter
must be added before compiling squid, when calling ./configure script.

So, in squid.spec for rpm build, when calling ./configure in section %build
, the following parameter should be added:

--enable-heap-replacement

( added of course before the commented # --enable-icmp )


Could you add this ?
Comment 1 Bill Nottingham 2000-02-08 12:40:59 EST
Sure, added in squid-2.3.stable1-4.

Note You need to log in before you can comment on or make changes to this bug.