Bug 90852 - apmd fails to turn on crond following LOWPOWER_SERVICES turn off
apmd fails to turn on crond following LOWPOWER_SERVICES turn off
Status: CLOSED DUPLICATE of bug 74935
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-14 13:28 EDT by Karsten Wade
Modified: 2015-01-07 19:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2003-05-14 13:28:29 EDT
Description of problem:

Default apmd installation sets the following parameter in /etc/sysconfig/apmd:

LOWPOWER_SERVICES="atd crond"

Following a low-power situation (or even a full battery drain and subsequent
system failure), crond fails to restart.

The hardware involved is a Dell Latitude C610 laptop.

I considered including crond in RESTORESERVICES, but the comment block
specifically says "Any valid service ... can be listed, and will be restarted if
it was running at suspend time."  Since apmd has already shutdown crond, I
presume it will not be restarted using RESTORESERVICES.

Version-Release number of selected component (if applicable):

  Red Hat Linux 8.0 2.4.18-27.8.0
  apmd-3.0.2-12
  vixie-cron-3.0.1-69

How reproducible:

As far as I can tell, every time.  I haven't done extensive experiments to see
if it is each time the battery gets to low power, or even what low power
percentage that is.  I also haven't checked to see if this is affected by doing
a suspend, although it definitely has happened without a suspend.

Steps to Reproduce:
1.  Unplug AC power from system
2.  Let system run until it reaches low-power threshold
3.  Plug back in and let battery charge, check to see if crond is running
    
Actual results:

crond is not restarted by apmd when coming back from a low-power battery situation

Expected results:

crond is restarted by apmd

Additional info:

I can presumably run some more tests, but they take some time and planning - it
takes a couple of hours for my battery to drain enough to go to a low-power
situation.  Let me know if this would be helpful.
Comment 1 Bill Nottingham 2003-05-19 16:30:59 EDT
Actually, I don't think the script handles the battery being refilled at all. :/
Comment 2 Aleksey Nogin 2003-05-30 05:42:28 EDT

*** This bug has been marked as a duplicate of 74935 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:53:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.