Bug 90911 - redhat-config-users allows creating group with the same group ID of another group
redhat-config-users allows creating group with the same group ID of another g...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 05:25 EDT by Paolo Prandini
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-23 10:10:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Prandini 2003-05-15 05:25:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When creating a new user, a private group with the same ID of the user is
created. This is well explained in Red Hat documentation. If you choose to
create a new group and add the group ID manually you can choose an existing
group ID.
After that you find yourself unable to delete the recently created group
because it results assigned to a user even if it's not. Thus you end up with
cross-linked groups.


Version-Release number of selected component (if applicable):
redhat-config-users-1.1.5-7

How reproducible:
Always

Steps to Reproduce:
1. Enter redhat-config-users
2. Choose create a new group (any name you like) and specify a manually an
existing group ID
3. By default 500 is proposed (or use an existing private user group)
4. Accept and press OK 
    

Actual Results:  You have now your user say Joe (UID 500) with his primary group
with the same name of the user, Joe (GID 500) and the new group, say mynewgroup
with GID 500. At this point the system gets confused. If you try to delete
mynewgroup with the GUI you receive a message that you cannot delete a user
primary group, and the group is not deleted, nor its assignement as primary
group of user Joe. If you try via command line (groupdel) you receive a message
that you cannot delete a user primary group.  This is not true because user
primary group has the same name of the user. Due to this cross-linked groups you
cannot remove mynewgroup from the group list.  

Expected Results:  The GUI should stop users from creating groups with an
already existing group ID, as groupadd does when using it in a root shell.

Additional info: 

You can solve the problem by editing the file /etc/group as root. Any change is
immediately reflected in the GUI if you press the refresh button. After that you
can easily remove the offending group using either the GUI or the command line
(groupdel).
Comment 1 Brent Fox 2003-05-19 21:06:42 EDT
The program doesn't let you delete a user's only private group because doing
that would leave the user without a group.  What you need to do is go delete the
user 'Joe'.  The program will then look to see if joe's private group has only
one user (joe).  If so, the program will delete the group when you delete the
user.  

Does this explain things better?
Comment 2 Brent Fox 2003-07-23 08:34:51 EDT
Oh, nevermind.  I see what you're saying now.  
Comment 3 Brent Fox 2003-07-23 10:10:21 EDT
I've added code that prevents the user from creating a user with an existing uid
and also from creating a group with an existing gid.

Should be fixed in redhat-config-users-1.1.11-1 in Rawhide.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.