Bug 90916 - [apr] .la files should not be shipped
Summary: [apr] .la files should not be shipped
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: apr (Show other bugs)
(Show other bugs)
Version: alpha 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-15 10:50 UTC by Enrico Scholz
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-15 14:10:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2003-05-15 10:50:34 UTC
[ I am entering it under the httpd component since apr/apr-util does not
  exist in bugzilla yet ]

Description of problem:

| $ rpm -ql apr-devel | grep \\.la
| /usr/lib/libapr-0.la

General consensus is that .la files should not be shipped. E.g. see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88187#c1


Version-Release number of selected component (if applicable):

apr-0.9.3-4

Comment 1 Joe Orton 2003-05-15 14:10:46 UTC
It's not generally true that .la files should not be shipped: any package which
uses libltdl relies on these files existing (though this does not include APR).

To some degree the .la files are a supported part of the APR interface, so I'd
not want to remove them as a packager.  Packages may rely on
`/usr/bin/apr-config --apr-la-file` working.


Note You need to log in before you can comment on or make changes to this bug.