Bug 90917 - [apr-util] Links against the wrong libdb-4
[apr-util] Links against the wrong libdb-4
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: apr-util (Show other bugs)
alpha 1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 07:24 EDT by Enrico Scholz
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version: 0.9.3-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-07 09:51:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-05-15 07:24:00 EDT
Description of problem:

When having compat-db installed, apr-util links against the old libdb-4.0
library instead of libdb-4.1:

| $ rpm --rebuild apr-util-0.9.3-4.src.rpm
| ...
| checking for db4/db.h... yes
| checking for db_create in -ldb4... no
| checking for db_create in -ldb-4.0... yes

New packages should not use the old db-4.0 library.


Version-Release number of selected component (if applicable):

apr-util-0.9.3-4
compat-db-4.0.14-2
Comment 1 Joe Orton 2003-05-15 10:17:20 EDT
Thanks, yes, I've seen this as well.
Comment 2 Joe Orton 2003-07-07 09:51:43 EDT
This was fixed a while back; thanks for the report.

* Thu May 15 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
- fix to try linking against -ldb first (#90917)

Note You need to log in before you can comment on or make changes to this bug.