Bug 90926 - KDE kernel config warn about error in a kernel config file
KDE kernel config warn about error in a kernel config file
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 09:49 EDT by Fulko Hew
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 09:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fulko Hew 2003-05-15 09:49:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When running the KDE control center Linux Kernel configuration tool it warns
about an error on line 83 of:
/usr/src/linux-2.4.20-13.9/drivers/net/wan/Config.in

The 'then' keyword should have been on the previous 'if' line.
Merge the two lines (83, 84) and the error goes away.

Version-Release number of selected component (if applicable):
kernel-2.4.20-13.9

How reproducible:
Always

Steps to Reproduce:
1. Run the kernel configurator within KDE control center.
   

Actual Results:  The kernel configuration could not be read due to the following
error: 
/usr/src/linux-2.4/drivers/net/wan/Config.in, line 84:
         then
^ parse error
Either your kernel sources contain invalid configuration rules or you just found
a bug in the KDE Kernel Configurator.

Expected Results:  No Error should have occured.

Additional info:
Comment 1 Phil Knirsch 2003-05-16 07:19:58 EDT
Just checked, really looks bad. This is a kernel bug though, kernelcfg has been
a tiny tool to edit modules.conf in the past (i don't think we actually ship it
anymore :-).

Reassigning to kernel.

Read ya, Phil
Comment 2 Arjan van de Ven 2003-05-22 05:36:06 EDT
thanks; fixing for next erratum

Note You need to log in before you can comment on or make changes to this bug.