Bug 9093 - RFE: rpm should attempt to catch certain errors with dependencies at build time
Summary: RFE: rpm should attempt to catch certain errors with dependencies at build time
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-03 13:41 UTC by Oliver Jones
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 19:40:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Jones 2000-02-03 13:41:56 UTC
RPM will happily build an rpm from a spec file that contains:

Provides: webserver mod_perl
Conflicts: apache apache-devel mod_perl

And then it will complain that mod_perl conflicts with the package when you
install it.  This confuses the user because mod_perl isnt installed.  RPM
shouldn't let you do such stupid things.

Comment 1 Jeff Johnson 2000-02-07 21:58:59 UTC
Currently it's the responsibility of the packager to "Don't do this". It's
not possible at this time to identify all (or even most of the important)
problems like this at build time. SOmeday ...

Comment 2 Jeff Johnson 2001-02-21 19:40:27 UTC
Changing component (and summary)

Comment 3 Jeff Johnson 2002-08-07 20:12:10 UTC
I don't believe that the problem of detecting self-conflicting
packages is generally solvable, nor even sufficiently solvable
to attempt a fix.


Note You need to log in before you can comment on or make changes to this bug.