Bug 90937 - IA32 microcode segfaults
IA32 microcode segfaults
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 12:10 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 14:00:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-05-15 12:10:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
IA32 microcode update segfaults with kernel-2.4.20-1.1990. This used to work
with pre-exec shield kernels (< -1.1976 I think)

[139 kajtzu@d106 ~]% sudo strace /sbin/microcode_ctl -ui
execve("/sbin/microcode_ctl", ["/sbin/microcode_ctl", "-ui"], [/* 43 vars */]) = 0
uname({sys="Linux", node="d106.fi.basen.net", ...}) = 0
brk(0)                                  = 0x838b000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=94242, ...}) = 0
old_mmap(NULL, 94242, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40017000
close(3)                                = 0
open("/lib/tls/libc.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0`V\351\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1537136, ...}) = 0
old_mmap(0xe80000, 1261352, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0xe80000
old_mmap(0xfaf000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x12f000) = 0xfaf000
old_mmap(0xfb2000, 7976, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xfb2000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4002f000
set_thread_area({entry_number:-1 -> 6, base_addr:0x4002f6c0, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}) = 0
munmap(0x40017000, 94242)               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++



Version-Release number of selected component (if applicable):
kernel-2.4.20-1.1990

How reproducible:
Sometimes

Steps to Reproduce:
1. run as root /sbin/microcode_ctl -ui
2.
3.
    

Actual Results:  Segfaults 80% of the time, otherwise it just fails miserably.

Expected Results:  Should not die on me.

Additional info:

[1 kajtzu@d106 ~]% rpm -q --qf '%{name} %{version} %{release} %{arch}\n' kernel
kernel-utils glibc
kernel 2.4.20 1.1990 i686
kernel-utils 2.4 8.28 i386
glibc 2.3.2 37 i686
Comment 1 Kaj J. Niemi 2003-05-23 05:01:16 EDT
Reproduceable with

kernel-2.4.20-20.1.1995.2.1.nptl (i686)
glibc-2.3.2-41 (i686)


Could this be related to bug #91401?
Comment 2 Kaj J. Niemi 2003-05-25 14:00:42 EDT
Seems to work again with kernel-2.4.20-20.1.2002.nptl.

Works for me.

Note You need to log in before you can comment on or make changes to this bug.