Bug 90953 - Menu entry should start htmlview, not mozilla
Menu entry should start htmlview, not mozilla
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: htmlview (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 14:46 EDT by Toralf
Modified: 2007-04-18 12:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:33:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-05-15 14:46:02 EDT
Description of problem:
The .desktop file included in the htmlview package (redhat-web.desktop) will
execute mozilla binary. Surely the htmlview utility itself is what you want?

Version-Release number of selected component (if applicable):
2.0.0-10
Comment 1 Mike A. Harris 2003-05-15 22:29:15 EDT
-bash-2.05b$ cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)

Below shows there are 3 files with that name in the distribution:

-bash-2.05b$ locate redhat-web.desktop
/var/lib/menu/kde/Applications/Internet/redhat-web.desktop
/usr/share/applications/redhat-web.desktop
/usr/share/desktop-menu-patches/redhat-web.desktop

The first and last files are actually symbolic links to the middle file:

-bash-2.05b$ ls -l /var/lib/menu/kde/Applications/Internet/redhat-web.desktop
/usr/share/applications/redhat-web.desktop
/usr/share/desktop-menu-patches/redhat-web.desktop
lrwxrwxrwx    1 root     root           42 Apr  3 16:09
/usr/share/applications/redhat-web.desktop ->
../desktop-menu-patches/redhat-web.desktop
-rw-r--r--    1 root     root         1527 Feb 18 10:27
/usr/share/desktop-menu-patches/redhat-web.desktop
lrwxrwxrwx    1 desktop  desktop        42 May 13 09:01
/var/lib/menu/kde/Applications/Internet/redhat-web.desktop ->
/usr/share/applications/redhat-web.desktop

The file owned by the htmlview package is only a symbolic link:

-bash-2.05b$ rpm -qf /usr/share/applications/redhat-web.desktop
htmlview-2.0.0-10

The 3rd file:

-bash-2.05b$ rpm -qf /var/lib/menu/kde/Applications/Internet/redhat-web.desktop
file /var/lib/menu/kde/Applications/Internet/redhat-web.desktop is not owned by
any package

That is probably a bug, as it should be owned by something, but that's another
story...

The actual file, is:

-bash-2.05b$ rpm -qf /usr/share/desktop-menu-patches/redhat-web.desktop
redhat-menus-0.38-1

As you can see it is owned by redhat-menus, not htmlview.

-bash-2.05b$ grep ^Exec /usr/share/desktop-menu-patches/redhat-web.desktop
Exec=mozilla %u

It does point to mozilla.  Wether that is a bug or not, or is intentional,
I'm not sure, however it isn't an htmlview bug.  I'll reassign this bug
report to the redhat-menus package and let the maintainer take over from
there.
Comment 2 Havoc Pennington 2003-05-15 22:55:28 EDT
The /usr/share/applications symlink should move from htmlview to mozilla most
likely. redhat-web.desktop used to run htmlview but that didn't work right
so now it doesn't.

Ignore /var/lib stuff, that's autogenerated and transient, should not 
be owned by anything.
Comment 3 Toralf 2003-05-16 03:14:41 EDT
Why would you want that (symlink in Mozilla)? Mozilla has got its own menu entry
already. And why can't you start htmlview? Seems to me that it works just fine,
but I haven't tested a lot; just replaced Exec, then tried once with default
settings, once with web browser changed to Galeon in Preferred Apps.
Comment 4 Mike A. Harris 2003-05-16 04:41:09 EDT
You've reassigned this back to htmlview, but it isn't clear to me how
this is an htmlview bug.  Are you saying that the file that htmlview
is pointing too is correct and/or won't change now or any time soon, and
so the symlink htmlview provides, it shouldn't be, because doing so makes
it invalid?  If that is the case, I can remove the symlink.

I am wondering however - what the deeper problem is here.  When you say:
"redhat-web.desktop used to run htmlview but that didn't work right
so now it doesn't.", what do you mean exactly?  Is htmlview buggy in some
way that should be fixed so this works?  Or should htmlview be removed?

I'd like to investigate the real problem here if possible, and fix that.

TIA for any clarifications



Note You need to log in before you can comment on or make changes to this bug.