Bug 91003 - utilities using fontconfig stop working when 1 (one) bad font is on its search path
utilities using fontconfig stop working when 1 (one) bad font is on its searc...
Status: CLOSED DUPLICATE of bug 87992
Product: Red Hat Linux
Classification: Retired
Component: fontconfig (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 06:59 EDT by Leonid I. Dimitrov
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid I. Dimitrov 2003-05-16 06:59:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

Description of problem:
When a font fontconfig doesn't like - for whatever reasons! - is on its search
path, then all graphical utilities using fontconfig - predominantly KDE and
GNOME - simply stop working with a message stating that probably fontconfig is
not configured correctly! This has as a consequence that the whole! X11 graphics
subsystem stops working at the next restart! It cost me days of annoyment and
work to locate this bug and the font file that caused it, but I still don't know
what should be wrong with that file - nautilus shows it - when NOT on the
fontconfig path! - as ok?

Version-Release number of selected component (if applicable):
fontconfig-2.1-9

How reproducible:
Always

Steps to Reproduce:
1.put a WRONG ttf file in one of the fontconfig search directories
2.fc-cache -f -v
3.nautilus
    

Actual Results:  none of the fontconfig using utilities works anymore
X server cant't be started at the next occasion

Additional info:
Comment 1 Owen Taylor 2003-05-16 10:34:47 EDT
We've had several reports of this, but we've never been able to 
identify a font with which I can reproduce this problem. 

What sort of "font fontconfig doesn't like" do you have?


*** This bug has been marked as a duplicate of 87992 ***
Comment 2 Leonid I. Dimitrov 2003-05-16 12:46:51 EDT
Oldengl.ttf
Comment 3 Leonid I. Dimitrov 2003-05-16 12:51:15 EDT
shall i send it to you? how? attached here?
Comment 4 Owen Taylor 2003-05-16 12:57:44 EDT
Depends on the license. If it's a proprietary font, please dont'
attach it. You can mail it to me and I'll delete it when I'm
done debugging the problem.

As important as the font is having the exact sequence of operations
that will take a functioning system with only the default fonts 
and by adding this font make it stop functioning.
Comment 5 Red Hat Bugzilla 2006-02-21 13:53:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.