Bug 91046 - apache logs hostnames with 'HostnameLookups off'
apache logs hostnames with 'HostnameLookups off'
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 15:31 EDT by Stephen Samuel
Modified: 2007-03-27 00:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-25 11:58:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The config file I'm using -- /etc/httpd/conf/httpd.conf (37.20 KB, text/plain)
2003-05-16 15:33 EDT, Stephen Samuel
no flags Details

  None (edit)
Description Stephen Samuel 2003-05-16 15:31:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030515

Description of problem:
Apache insists on logging hostnames even though I've specified 
 'HostnameLookups off'
all over the httpd.conf file.

it seems to be acting as if hostnamelookups is on, but I can' find anywhere that
this is happening.

This bug has appeared since about the time I installed 8.0.  Config files I've
generated since then have all exhibited this problem.


Version-Release number of selected component (if applicable):
httpd-2.0.40-21.1

How reproducible:
Always

Steps to Reproduce:
1. Install the attached httpd.conf file
2.  go to web pages
3. check access.conf
    

Actual Results:  ip2-162.vancbc01g01.dialup.ca.telus.com - -
[16/May/2003:11:11:40 -0700] "GET /MSADC/root.exe?/c+dir HTTP/1.0" 404 1041 "-" "-"


Expected Results:  207.6.103.162- - [16/May/2003:11:11:40 -0700] "GET
/MSADC/root.exe?/c+dir HTTP/1.0" 404 1041 "-" "-"

Additional info:
Comment 1 Stephen Samuel 2003-05-16 15:33:37 EDT
Created attachment 91743 [details]
The config file I'm using -- /etc/httpd/conf/httpd.conf
Comment 2 Joe Orton 2004-01-08 12:03:50 EST
This is like a configuration error: in the Directory sections at the
end of the file, you have:

        Allow from from all

the second "from" will be interpreted as a hostname which is allowed,
causing Apache to do reverse lookups on all requests.
Comment 3 Joe Orton 2004-01-08 12:04:06 EST
This is a configuration error: in the Directory sections at the end of
the file, you have:

        Allow from from all

the second "from" will be interpreted as a hostname which is allowed,
causing Apache to do reverse lookups on all requests.
Comment 4 Joe Orton 2004-03-25 11:58:50 EST
Preume this is a config error as above; please reopen otherwise.

Note You need to log in before you can comment on or make changes to this bug.