Bug 91069 - (IDE DMA)Can't mount CD: "tray open" messages
(IDE DMA)Can't mount CD: "tray open" messages
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-05-17 05:46 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
filled "reporting-bugs" form from kernel source (27.37 KB, text/plain)
2003-05-17 06:00 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-05-17 05:46:35 EDT
Description of problem:
Can't mount CD on my (old) computer
(Mounting CD's in Red Hat Linux 9 installer (both auto and
in Ctrl-Alt-F2 console) worked fine.)
I then reinstalled RHL9 and after installation
got the same situation...

My previously installed Linux was Red Hat Linux 8, 
(kernel 2.4.18-4), and in this version of Linux all my CD's mounted ok.

Older versions of Linux (debian 2.2, 3.0) and Windows worked fine too...

System BIOS: Award Modular BIOS v4.51PG
BIOS ID: 07/21/97-i430TX-2A59ISM9C-00
System Chipset: Intel Corporation 82439TX 430TX System Controller
System Mainboard Model: ACORP-5TX32 Ver.C 08/07/1997

Version-Release number of selected component (if applicable):

How reproducible:
always on my computer (see hardware list above)

Steps to Reproduce:
1. mount /dev/cdrom
Actual results:
ide-floppy driver 0.99.newide
hdc: ATAPI 20X CD-ROM drive, 0kB Cache, DMA
hdc: tray open
end_request: I/O error, dev 16:00 (hdc), sector 64
repeats last two messages 20 times, then prints
mount: not a directory
and does not mount CD.
Expected results:
normal mounting

Additional info:
Comment 1 Need Real Name 2003-05-17 06:00:38 EDT
Created attachment 91755 [details]
filled "reporting-bugs" form from kernel source

Included in this attachment are logs of console, /var/log/messages,
/var/log/dmesg, processor and harware information, etc.
Comment 2 Need Real Name 2003-05-22 09:18:08 EDT
by qwezxcasd@mail.ru:
Temporarily bugfix:
Ater disabling DMA (by running hdparm -d0 /dev/hdc) everything works fine.
Comment 3 Alan Cox 2003-06-08 09:36:41 EDT
Looks like this CD needs adding to the nodma blacklist. Thanks
Comment 4 Bugzilla owner 2004-09-30 11:40:57 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.